WebPagetest Forums
Keeping Test State - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Bugs/Issues (/forumdisplay.php?fid=10)
+--- Thread: Keeping Test State (/showthread.php?tid=10068)



Keeping Test State - LeptienM - 11-29-2011 08:32 PM

Hi!

I think there is a "bug" in the public Webfrontend at http://www.webpagetest.org.

After conducting a test, when I navigate via <Back>-Button of the Browser to the Test Setup, it kept state for stuff like URL, Scripts, Location etc.
But the Test-Browser always falls back to IE7 (probably the first Browser in the list), even if I actually picked IE9 when I first set up the test. I think this should be consistent. Either loose all the test context. Or keep all of it.
You don't want to know how often I had to repeat a test, because I forgot to reconfigure the Test Browser. :-)

Btw, you announced, that Firefox support will come soon to other locations. Any news on that? Especially for a European node? :-)

Best wishes,
Markus


RE: Keeping Test State - pmeenan - 11-30-2011 04:33 AM

Yeah, that's a UI annoyance that has been bothering me for a while, I just haven't gone in and fixed it yet. The dropdowns for the browser and connectivity are initialized in javascript so I need to carry some state around, otherwise the form gets into a bad state and you submit tests for a location other than what the UI is displaying.

On Firefox, I might be able to deploy to the Frankfurt node since I have direct access to that machine. I've been holding off until I find a good way to keep up with their updates now that they are on a 6 week release cycle (chrome does a nice silent automatic update but Firefox isn't quite as smooth)