WebPagetest Forums
The real speed of loading web site - Printable Version

+- WebPagetest Forums (http://www.webpagetest.org/forums)
+-- Forum: Web Performance (/forumdisplay.php?fid=3)
+--- Forum: Discuss Test Results (/forumdisplay.php?fid=4)
+--- Thread: The real speed of loading web site (/showthread.php?tid=10462)



The real speed of loading web site - sweb - 01-26-2012 12:57 AM

Hi all,
I know that it takes time to speed up site load ... and I have invested some time on this issue.
A few days ago my friend recommended the site to test
http://www.webpagetest.org

and to do a comparison. Incredibly, his load of 1.5 seconds and my site by 7.8 seconds. I took pictures, cleaned up code, CSS, and the same is repeated in the result. What could be a problem. He told me that my hosting is not good quality. Is that correct, and what else do I need to obat attention? I would like to keep my slider, but if it is a problem I will find another solution...Test my site is located at:http://www.webpagetest.org/result/120125_6W_3027R/1/details/

Any small suggestions will help me a lot

Thanks!


RE: The real speed of loading web site - pmeenan - 01-26-2012 02:16 AM

I don't see any problems with the hosting but it does look like there are a fair number of things you could do for a pretty quick win:

1 - Test http://www.swebdizajn.com instead of swebdizajn.com. That will eliminate the first redirect and your results will be 0.5 sec faster

2 - Fix the javascript blocking. You have 4 javascript files loading serially, each blocking execution. I've honestly never seen that happen for sequential scripts referenced from the HTML but if I had to guess I would say that a simple elimination of the line break between the script tags might fix it.

Change this:

Code:
<script type="text/javascript" src="js/jquery-1.4.2.js">
</script>
<script type="text/javascript" src="js/jquery-swebdizajn.js">
</script>
<script type="text/javascript" src="js/jquery.lavalamp.js">
</script>
<script type="text/javascript" src="js/lavalamp-functions.js">
</script>

to:

Code:
<script type="text/javascript" src="js/jquery-1.4.2.js"></script>
<script type="text/javascript" src="js/jquery-swebdizajn.js"></script>
<script type="text/javascript" src="js/jquery.lavalamp.js"></script>
<script type="text/javascript" src="js/lavalamp-functions.js"></script>

It is possible that IE thinks there is some inline script in there that needs to be executed. If you can, you should also try to move those scripts and all of the javascript that depends on them to the end of the page so that the user experience will be faster.

3 - Do you actually use/need bg-glow.png? I couldn't see it when I loaded the page and I'd be surprised if anyone noticed it even if you do. I'd recommend removing it.

4 - All of the images for the header are loading at the same time. I'd recommend only loading the visible one and then load the rest after onLoad and trigger the rotation after they have loaded.


RE: The real speed of loading web site - sweb - 01-26-2012 11:02 PM

I hope that the removal of graphics and navigation css instead of JS, contribute to the improvement. I made small changes to your recommendation, removed non-existing images, and it is noticeable acceleration site for about 10%. After sorting tags, we will see results.


RE: The real speed of loading web site - pmeenan - 01-26-2012 11:20 PM

Actually, I think this is the source of the blocking j http://blogs.msdn.com/b/ieinternals/archive/2010/04/01/ie8-lookahead-downloader-fixed.aspx

Basically, you need to add the charset to your content-type HTTP header response. Instead of:

Code:
Content-Type: text/html

it needs to be

Code:
Content-Type: text/html; charset=utf-8

Otherwise IE8's look-ahead prefetcher will break and you will get the blocking behavior you are seeing.


RE: The real speed of loading web site - sweb - 01-28-2012 03:28 AM

I went in ordering code. I have a small problem with the .htaccess file. If I put this file as:

Options +FollowSymLinks
RewriteEngine On
RewriteBase /
rewritecond %{http_host} ^domain.com [nc]
rewriterule ^(.*)$ http://www.domain.com/$1 [r=301,nc]

RewriteCond %{HTTP_HOST} ^domain.com$ [NC]
RewriteRule ^(.*)$ http://www.domain.com/$1 [R=301,L]

Site can not be loaded (internal server Erorr 500) ... and when I download the
"Options +FollowSymLinks" it's working normally.
Where I am wrong and how it should look like what .htacces file if you do not want to appear to me to www and the URL is correct?


RE: The real speed of loading web site - MaxRiv - 02-02-2012 08:13 AM

(01-26-2012 12:57 AM)sweb Wrote:  I know that it takes time to speed up site load ... and I have invested some time on this issue.

Try http://www.unshit.com
maybe it's a bit weird tool, but it's very effective
it just poins out what you need to fix first
then come back to this site and measure the speed again


RE: The real speed of loading web site - MaxRiv - 02-02-2012 08:17 AM

Too many css files, you need to combine them. Many jpg files are not optimized.
bg-header.gif - 404 error


RE: The real speed of loading web site - sweb - 02-03-2012 12:08 AM

A very powerful tool. Yes, there are multiple css files which will also connect and optimize all the JPEG files. I move with the repairs. Thank you very much!