WebPagetest Forums
mod_pagespeed combine js isn't working - help needed - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Bugs/Issues (/forumdisplay.php?fid=10)
+--- Thread: mod_pagespeed combine js isn't working - help needed (/showthread.php?tid=11027)



mod_pagespeed combine js isn't working - help needed - Yaron - 04-23-2012 09:09 PM

Hi,

I have a probelm once configuring webpagetest private instance on windows, and ubuntu with apache 2.2.14, mod_pagespeed 0.10.21.2-1381 with mod_proxy enabled, and for some reason only files text/html are having the x-mod-pagespeed header.
it looks like the defaulttype on apache is taking priority -
"DefaultType text/plain"

i've configuered the SetOutputFilter MOD_PAGESPEED_OUTPUT_FILTER MOD_PAGESPEED_OUTPUT_FILTER

and under pagespeed.conf i've configuered -
AddOutputFilter MOD_PAGESPEED_OUTPUT_FILTER text/html text/javascript application/x-javascript
AddOutputFilter MOD_PAGESPEED_OUTPUT_FILTER application/x-httpd-php

i've tried also to use the apache in server mode, and the result was the same.

is there any configuration that can be done to overcome this issue?(if there is need for complete configuration or any other extra info please ask)


Thanks,
Yaron


RE: mod_pagespeed combine js isn't working - help needed - pmeenan - 04-23-2012 10:28 PM

Sorry, I haven't tried configuring WPT to go through mod_pagespeed before - odds are it is something with dynamic content coming from PHP and the mime types may not be working right.

You should ask over in the mod_pagespeed discussion group (the team is great about responding quickly and helping sort the configs out): http://groups.google.com/group/mod-pagespeed-discuss

Thanks,

-Pat