WebPagetest Forums
slow test - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: Web Performance (/forumdisplay.php?fid=3)
+--- Forum: Discuss Test Results (/forumdisplay.php?fid=4)
+--- Thread: slow test (/showthread.php?tid=1122)

Pages: 1 2


RE: slow test - nepd - 08-04-2011 02:08 AM

Patrick-

Reading up on W3TC and it says that I should NOT minify the js ads? Is that accurate?


RE: slow test - pmeenan - 08-04-2011 03:24 AM

Most of the ads js should come from a 3rd party domain and not something you serve. You should only combine and minify the files being served directly for your page.


RE: slow test - dmckinney5 - 08-04-2011 05:01 AM

"3 - Go to the minify settings and go through the help wizard to combine your css and javascript files. It looks like you have over 8 css files and over 20 javascript files). Get them down to a manageable number (1-2 of each)."

Trying to do this in preview mode and when i save the setting and view preview all i get is a blank page any ideas?


RE: slow test - nepd - 08-04-2011 06:38 AM

So I've installed W3TC. Here are my new results:

http://www.webpagetest.org/result/110803_1Q_17PRH/

Getting a lot where the repeat visit is higher - then sometimes the repeat is like 2.5 seconds.

I have the following things enabled in W3TC (marked with *)

HTML / XML
Enable*
Inline CSS minification*
Inline JS minification*
Don't minify feeds
Line break removal*

JAVAScript
Enable*
Combine only after <head>
Combine only after <body>
Combine only before </body>
Preserved comment removal (not applied when combine only is active)
Line break removal (not safe, not applied when combine only is active)

CSS
Enable*
Combine only
Preserved comment removal (not applied when combine only is active)
Line break removal (not applied when combine only is active)

Anything else I should enable here? I also enabled, page, database, object, and browser cache with etags and set headers.
Another example:

http://www.webpagetest.org/result/110803_BZ_17PTA/


RE: slow test - pmeenan - 08-04-2011 10:48 AM

You should also take a look at the browser cache support. Looks like the static images could use some browser-side caching.

The onload looks to be firing at different points in the waterfall for first and repeat views. You might have some async activity that is just getting caught in the repeat view. You should try doing a video capture and take a look at the filmstrip views for the first and repeat views to see how they look visually.

Most of the remaining requests look to be a (lot) of ad requests so those are largely going to be out of your control.


RE: slow test - nepd - 08-04-2011 10:57 AM

(08-04-2011 10:48 AM)pmeenan Wrote:  You should also take a look at the browser cache support. Looks like the static images could use some browser-side caching.

The onload looks to be firing at different points in the waterfall for first and repeat views. You might have some async activity that is just getting caught in the repeat view. You should try doing a video capture and take a look at the filmstrip views for the first and repeat views to see how they look visually.

Most of the remaining requests look to be a (lot) of ad requests so those are largely going to be out of your control.

Thanks again. Do I have my ads set up efficiently? I set up divs where I wanted them and then used loaders at the bottom of my page to place them where they go.