WebPagetest Forums
Facebook authentication - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: Web Performance (/forumdisplay.php?fid=3)
+--- Forum: Testing Tools/Services (/forumdisplay.php?fid=6)
+--- Thread: Facebook authentication (/showthread.php?tid=11504)



Facebook authentication - Matthieu - 08-02-2012 06:35 PM

Hi,

I've a question, is it possible to test a facebook application, who require to be authenticated on Facebook?

If the answer is yes, how can I do that?

Thanks in advance.


RE: Facebook authentication - pmeenan - 08-03-2012 12:53 AM

It's possible using a script - https://sites.google.com/a/webpagetest.org/docs/using-webpagetest/scripting


RE: Facebook authentication - Matthieu - 08-03-2012 11:24 PM

Thanks for your answer Patrick. I'll check this documentation.


RE: Facebook authentication - Matthieu - 08-04-2012 01:01 AM

Hummm, it's not working.
I've try with this script:

navigate http://www.facebook.com/index.php
setValue id=email myemail@hello.com
setValue id=pass mypassword
sendKeyDownAndWait ENTER


I think the problem is that facebook doesn't like the automatisation tools because the id of the connexion button is generated at each loading of the authentication page.

Maybe have you an idea to bypass it?


RE: Facebook authentication - pmeenan - 08-04-2012 01:07 AM

instead of the sendKeyDownAndWait you should just:

submitForm login_form

You can also send clicks to the button but it doesn't actually HAVE an ID so you'd have to use a different selector (worst case, the innerHtml match will work).


RE: Facebook authentication - Matthieu - 08-06-2012 07:04 PM

Humm, with that:

navigate http://www.facebook.com/index.php
setValue id=email myemail@hello.com
setValue id=pass mypassword
submitForm login_form

I've the same issue, on the screenshot I can see, the email and the password who have been set but not validated...


RE: Facebook authentication - Matthieu - 08-08-2012 08:32 PM

Sorry it's me. It works fine.

Thanks a lot Patrick Smile