WebPagetest Forums
video no working(agent android Nexus S ) - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Bugs/Issues (/forumdisplay.php?fid=10)
+--- Thread: video no working(agent android Nexus S ) (/showthread.php?tid=11517)



video no working(agent android Nexus S ) - Quincy - 08-06-2012 02:21 PM

With selecting "video" option, testing works fine. However when I want to create the video, it just hangs on "Your video will be available shortly, please wait..."

I check /results/$test_id/ dir, there is no video.mp4. I want to know the video.mp4 is created by server or uploaded by agent. Please give me a hand.

I just know in pc agent, there is avisynth to create mp4.

client: Google Nexus S. code here: http://code.google.com/p/mobitest-agent/source/browse/#svn%2Ftrunk%2Fmobitest-agent%2FAndroid%2FBZAgent

server: webpagetest2.5(ubuntu)


RE: video no working(agent android Nexus S ) - pmeenan - 08-06-2012 10:04 PM

Videos are rendered by URLBlast so you need a Windows machine/agent running if you want videos to be created. We have a long-term todo to render videos on the server but right now they depend on AVISynth for doing the layout and it is Windows-specific.


RE: video no working(agent android Nexus S ) - Quincy - 08-07-2012 01:16 PM

(08-06-2012 10:04 PM)pmeenan Wrote:  Videos are rendered by URLBlast so you need a Windows machine/agent running if you want videos to be created. We have a long-term todo to render videos on the server but right now they depend on AVISynth for doing the layout and it is Windows-specific.

I doubt that the video function is Window-specific, beacuse when I choose Nexus S(Android 2.3.3) in the portal of webpagetest to test m.google.com, I can watch the video which android agent uploads. You can watch the video( http://www.webpagetest.org/video/view.php?id=120807_6R_4MT.1.0 ) and see my test( http://www.webpagetest.org/result/120807_6R_4MT/ )。

The main question is that how the android phone creates the video.


RE: video no working(agent android Nexus S ) - pmeenan - 08-07-2012 11:20 PM

The video support in WebPagetest is done in 2 parts:

1 - All of the agents can capture screen shots at regular intervals and upload them to the server as part of the test results. These individual screen shots are what you see in the filmstrip view.

2 - When you request a video (either for one test or multiple compared) the server packages up the individual screen shots and builds a rendering script. Windows agents running urlblast.exe pick up the rendering task, create the video and upload it back to the server.

The actual rendering of the video has nothing to do with the device that the screen shots were captured on.

I wrote the code. I can GUARANTEE that you will not be able to render videos unless you have at least one windows computer with avisynth installed running urlblast.


RE: video no working(agent android Nexus S ) - Quincy - 08-08-2012 11:31 AM

(08-07-2012 11:20 PM)pmeenan Wrote:  The video support in WebPagetest is done in 2 parts:

1 - All of the agents can capture screen shots at regular intervals and upload them to the server as part of the test results. These individual screen shots are what you see in the filmstrip view.

2 - When you request a video (either for one test or multiple compared) the server packages up the individual screen shots and builds a rendering script. Windows agents running urlblast.exe pick up the rendering task, create the video and upload it back to the server.

The actual rendering of the video has nothing to do with the device that the screen shots were captured on.

I wrote the code. I can GUARANTEE that you will not be able to render videos unless you have at least one windows computer with avisynth installed running urlblast.

Got it, thank you.