WebPagetest Forums
pcap2har - appears no results are returned - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Bugs/Issues (/forumdisplay.php?fid=10)
+--- Thread: pcap2har - appears no results are returned (/showthread.php?tid=12648)



pcap2har - appears no results are returned - sduelund - 11-13-2013 03:56 PM

Hey Pat,

I been trying to get Webpage test agent working on Android for a while and over the last few days i think ive narrowed down to why im getting the missing data.

the pcap2har under mobile folder appears to be none functional. Ive run the htm version and it returns a ok request but its empty. If i run the python script on the server, the main.py is able to successfully translate the .pcap and .cap files to .har. However if i push anything through the pcap2har.php, i get the response code 200 OK, but no file and no text.

I have tried updating the php and pcap2har to the latest versions but no dice.

Any ideas?



this is required for the android agent to work, it calls the pcap2har.php to convert the pcap files.

(I have fixed all other "bugs" in the app other than this one... and im stuck)

cheers
Steffen
http://www.ovalis.com.au


RE: pcap2har - appears no results are returned - pmeenan - 11-19-2013 01:13 AM

Not sure if it's possible to attach files to github issues but if so, could you attach an example pcap and open a bug?

That said, the mobitest agents themselves aren't getting a lot of dev these days and most of the efforts on mobile testing have moved over to the NodeJS agent (which uses remote dev tools and can drive both Safari and Chrome). If you haven't tried using it yet I highly recommend it: https://github.com/WPO-Foundation/webpagetest/tree/master/agent/js