WebPagetest Forums
Time To First Byte Question - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: Web Performance (/forumdisplay.php?fid=3)
+--- Forum: Discuss Test Results (/forumdisplay.php?fid=4)
+--- Thread: Time To First Byte Question (/showthread.php?tid=13085)



Time To First Byte Question - Webnauts - 07-11-2014 07:54 PM

Any suggestions to improve TFTB for this site? http://www.webpagetest.org/result/140711_0H_W1J/

1. It runs on OpenCart, but we cache locally, so we do not call the DB anymore, which previously was causing a far higher TFTB.

2. Running on a VPS box on MT Temple.

3. We are aware of the rendering blocking of CSS and JS which we are currently working on.

4. The site goes public via proxy (Sucuri Proxy Firewall). Nothing changed comparing to before we went with that.

5. Using Google ModSpeed.

6. Using an excellent external DNS service of Dyndns.

7. Not aware of any bottlenecks.

Any idea which checkbox we didn't check?

Thanks in advance.


RE: Time To First Byte Question - Chris Stark - 07-12-2014 04:52 AM

You probably want to try running newrelic to see whats going on inside the server.


RE: Time To First Byte Question - andydavies - 07-16-2014 07:10 PM

It's well worth doing more than one test just to ensure the server is warmed up and confirm it's not just a single test that's bad.

Don't know whether you've changed anything but in this test run of 9 http://www.webpagetest.org/result/140716_GT_3a418bdbf05071a78b0688944a0facf6/ TTFB looks like

On the other hand Pingdom's RUM beacon looks like its got a few issues but at least it's not blocking