WebPagetest Forums
ffmpeg / libav - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Private Instances (/forumdisplay.php?fid=12)
+--- Thread: ffmpeg / libav (/showthread.php?tid=13688)



ffmpeg / libav - nilskuhn - 04-21-2015 08:54 PM

Hi,
is ffmpeg obligatory on server side or does wptserver work with fork avconv/libav-tools, too?
Regards, Nils


RE: ffmpeg / libav - pmeenan - 04-21-2015 10:40 PM

I am pretty sure it needs ffmpeg proper. I know if you are doing mobile testing it absolutely needs ffmpeg because it relies on filters that the fork doesn't contain. For server-side video rendering it needs ffmpeg with x264 support and I don't know if the fork uses the same command-line.


RE: ffmpeg / libav - pmeenan - 04-21-2015 10:42 PM

Fwiw, I have the 64-bit static build of ffmpeg for linux here if you want to use it: http://www.webpagetest.org/software/ffmpeg

I'm running ubuntu which uses the avconv fork and ununstalled it and manually installed the static ffmpeg build (I think there was also a PPA with it but I had issues getting it to install).


RE: ffmpeg / libav - nilskuhn - 04-22-2015 12:12 AM

thanks for informations

With ubuntu I use PPA:
Code:
add-apt-repository ppa:jon-severinsson/ffmpeg
apt-get update
apt-get install ffmpeg
That works.

Older debian releases had ffmpeg in their repositories. But with actual debian jessie I can't get ubuntu PPA installation to work Sad
Is it just the ffmpeg binary you offered which must be available in /usr/bin/ ?


RE: ffmpeg / libav - pmeenan - 04-22-2015 12:22 AM

It doesn't have to be the one I offered, any mainline build will work (at least with newer WPT releases). You can grab Jon's versions from here: http://johnvansickle.com/ffmpeg/


RE: ffmpeg / libav - nilskuhn - 04-22-2015 01:47 AM

thanks, works for me.