WebPagetest Forums
Chrome Tests Fail with Error: "Timed out waiting for the browser to start." - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Private Instances (/forumdisplay.php?fid=12)
+--- Thread: Chrome Tests Fail with Error: "Timed out waiting for the browser to start." (/showthread.php?tid=13701)



Chrome Tests Fail with Error: "Timed out waiting for the browser to start." - nweinert - 05-02-2015 03:06 AM

Every time I run a test on my private instance it fails with the following error: "Timed out waiting for the browser to start."

I have the server running on WAMP locally and am using the same machine as the test agent. I can see the wptdriver pick up the test request and open a Chrome browser - it navigates succesfully to my localhost/blank.html then does nothing. After a short time the test fails and the Chrome browser is closed. Any help debugging would be greatly appreciated.

Thanks,
Noah


RE: Chrome Tests Fail with Error: "Timed out waiting for the browser to start." - andydavies - 05-05-2015 06:50 AM

What OS (and 32 vs 64 bit) is the test agent running, what browser is failing, are any other browser configured and do they work?

Is DummyNet configured correctly?


RE: Chrome Tests Fail with Error: "Timed out waiting for the browser to start." - nweinert - 05-06-2015 12:22 AM

Thanks for the reply.

I am running Win7x64 and using Chrome.
This is the first browser I have tried to configure.

When running tests I was getting an error asking if IPFW+DummyNet was installed every time I ran a test. It is installed, I uninstalled/reinstalled it many times to try to resolve that issue. I made sure to set my machine to test mode before the installation, I could not seem to get it to work. Given that I don't need to test on varying connection types, I used a workaround and set Connectivity=LAN in order to bypass this error.


RE: Chrome Tests Fail with Error: "Timed out waiting for the browser to start." - smartyshal - 05-22-2015 07:14 AM

I'm facing the exact issue and am wondering if you have any solution yet.

Thanks!


RE: Chrome Tests Fail with Error: "Timed out waiting for the browser to start." - ppoojavermaa - 05-22-2015 09:41 PM

I am facing the same issue.
Every website is open perfectly expect of yours and http://www.showboxdownloadapp.com


RE: Chrome Tests Fail with Error: "Timed out waiting for the browser to start." - ravihumint - 09-09-2016 05:54 PM

Hello, we are also facing similar issue, I have tried it multiple times, but it always just throws the same error. By the way if it helps, we are hosted on Microsoft Azure and are behind Cloudflare. We were earlier also using CloudFlare and the only thing new here is Azure, hopefully that's not the reason. Site in question: https://www.wethechic.com