WebPagetest Forums
Persisting test results to S3 - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Bugs/Issues (/forumdisplay.php?fid=10)
+--- Thread: Persisting test results to S3 (/showthread.php?tid=13800)



Persisting test results to S3 - bigb21985 - 06-30-2015 06:58 AM

Hi,

I created WPT Private instance on Amazon EC2 and configured it to archive test results to Amazon S3. It worked fine for few months but all of sudden all my tests started failing with error "Error in submitting URL".

After reading few posts, I got to know that it might be due to low memory on sever. I restarted my server but it didn't help. On restart, Public DNS for instance was changed and I was not able to access my old test results. Also I was not able to test any url on that server.

Finally I created a new server instance using same key and S3 setting thinking that I would be able to recover my old results. I'm not able to access old test results archived in S3 with this new instance.

I referred http://calendar.perfplanet.com/2014/webpagetest-private-instances-in-five-minutes/ for the setup.

Thanks in advance.

Regards,
Bhavesh


RE: Persisting test results to S3 - pmeenan - 06-30-2015 07:38 AM

If you have a S3 URL in your settings.ini try getting rid of that. There was a change a while back to upload results as private instead of public and it will normally restore fine using the API but if an URL is present it will try that (and fail if they are private).


RE: Persisting test results to S3 - bigb21985 - 06-30-2015 07:51 AM

(06-30-2015 07:38 AM)pmeenan Wrote:  If you have a S3 URL in your settings.ini try getting rid of that. There was a change a while back to upload results as private instead of public and it will normally restore fine using the API but if an URL is present it will try that (and fail if they are private).

I had following in my settings.ini. I just commented out archive_s3_url
and restarted nginx service. But still I'm not able to access old results.

archive_s3_server=s3.amazonaws.com
archive_s3_key=<access key>
archive_s3_secret=<secret>
archive_s3_bucket=<bucket>
archive_s3_url=http://s3.amazonaws.com/

Thanks,
Bhavesh

Issue was with a particular result only. I'm able to access all other old results.
Smile

Thanks a lot Patrick!!

Regards,
Bhavesh


RE: Persisting test results to S3 - MachMetrics - 02-01-2018 08:03 AM

(06-30-2015 07:38 AM)pmeenan Wrote:  If you have a S3 URL in your settings.ini try getting rid of that. There was a change a while back to upload results as private instead of public and it will normally restore fine using the API but if an URL is present it will try that (and fail if they are private).

Just wanted to chime in that I was having the same issue (would archive to s3, but not pull back down) and commenting out the s3 url in the settings fixed it for me. Thanks Patrick!