WebPagetest Forums
Authentication in Non-U.S. Regions - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Private Instances (/forumdisplay.php?fid=12)
+--- Thread: Authentication in Non-U.S. Regions (/showthread.php?tid=14156)



Authentication in Non-U.S. Regions - tonyerwin - 01-11-2016 04:36 AM

Hi, All,

Since about September I'm been successfully running AWS EC2 private instances from 9 different regions (us-east-1, us-west-1, us-west-2, eu-central-1, eu-west,1, ap-northeast-1, ap-southeast-1, ap-southeast-2, sa-east-1). However, about Jan 7, all of my non-U.S. regions started failing. I see lots of errors like these in the error log for non-U.S. regions:

01:40:03 - EC2:Launching EC2 instance. Region: ap-northeast-1, AMI: ami-27b28026, error: AWS was not able to validate the provided access credentials
01:40:04 - EC2:Launching EC2 instance. Region: sa-east-1, AMI: ami-eda611f0, error: AWS was not able to validate the provided access credentials
01:42:20 - EC2:Launching EC2 instance. Region: eu-west-1, AMI: ami-d0c76fa7, error: AWS was not able to validate the provided access credentials
01:45:02 - EC2:Listing running EC2 instances: AWS was not able to validate the provided access credentials
01:45:02 - EC2:Launching EC2 instance. Region: eu-west-1, AMI: ami-d0c76fa7, error: AWS was not able to validate the provided access credentials
01:45:03 - EC2:Launching EC2 instance. Region: eu-central-1, AMI: ami-54291f49, error: AWS was not able to validate the provided access credentials
01:45:04 - EC2:Launching EC2 instance. Region: ap-southeast-1, AMI: ami-7a2e0e28, error: AWS was not able to validate the provided access credentials
01:45:05 - EC2:Launching EC2 instance. Region: ap-southeast-2, AMI: ami-55a8c46f, error: AWS was not able to validate the provided access credentials
01:45:05 - EC2:Launching EC2 instance. Region: ap-northeast-1, AMI: ami-27b28026, error: AWS was not able to validate the provided access credentials
01:45:06 - EC2:Launching EC2 instance. Region: sa-east-1, AMI: ami-eda611f0, error: AWS was not able to validate the provided access credentials


Any ideas?

Thanks,
Tony


RE: Authentication in Non-U.S. Regions - tonyerwin - 01-13-2016 05:03 PM

FWIW, authentication to non-U.S. regions started working again not terribly long after I posted my message. No known reason why it stopped working for a few days or why it started working again. Smile