WebPagetest Forums
Problem with video combine with script - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Private Instances (/forumdisplay.php?fid=12)
+--- Thread: Problem with video combine with script (/showthread.php?tid=144)



Problem with video combine with script - teun - 01-14-2010 07:55 PM

I'm trying to run a script on my installation of webpagetest. I first load a page, then enter search term and hit search. Works pretty good. But now, I want to make a video out of it and for some reason this freezes the browser on the testing machine.

Example:
This works:
http://myserver/runtest.php?f=xml&url=http://www.google.nl/resulaat/&location=Test_Ethernet&runs=5&script=logData%090%0D%0A%0D%0A%2f%2f+put+any+urls+you+want+to+navigate%0D%0A​navigate%09http%3a%2f%2fwww.google.nl%0D%0A%0D%0AlogData%091%0D%0A%0D%0A%2f%2f+t​his+step+will+get+recorded%0D%0A%0D%0AsetValue%09name%3dq%09funda%0D%0AclickAndW​ait%09name%3dbtnG%0D%0A%0D%0A

This does not:
http://myserver/runtest.php?f=xml&url=http://www.google.nl/resulaat/&location=Test_Ethernet&runs=5&script=logData%090%0D%0A%0D%0A%2f%2f+put+any+urls+you+want+to+navigate%0D%0A​navigate%09http%3a%2f%2fwww.google.nl%0D%0A%0D%0AlogData%091%0D%0A%0D%0A%2f%2f+t​his+step+will+get+recorded%0D%0A%0D%0AsetValue%09name%3dq%09funda%0D%0AclickAndW​ait%09name%3dbtnG%0D%0A%0D%0A&video=1

The only difference is the appended &video=1.

On this box, I can grab video screenshots without any problem, as long as I don't use hosted scripts. Plain URL tests can use the video=1 parameter.

It seams that the live version has the same problem: http://www.webpagetest.org/result/100112_47MW/

Known issue? I use the 1.7 release. Would it help to upgrade to head revision?

Thanks in advance,
Teun


RE: Problem with video combine with script - pmeenan - 01-15-2010 06:14 AM

It probably won't help to upgrade. The video recording is still very new and I haven't done any testing with it and scripted tests. The scripted test support in general is pretty weak and needs a lot of work. I'm not entirely sure when I'll get aa chance to look at it though as I have some other things I need to work on first.

Thanks,

-Pat


RE: Problem with video combine with script - teun - 01-15-2010 05:37 PM

Thanks a lot for the prompt response. OK, that's clear. Be assured that I am very happy with the parts the I did manage to get to work.

Is UrlBlast.exe itself open source? I'm not much of a C++ hero, but I could at least try to help.

Thanks,
Teun


RE: Problem with video combine with script - pmeenan - 01-15-2010 09:42 PM

Yes, the whole system is open source with the code available here: http://code.webpagetest.org/svn

The c++ bits (pagetest.exe, pagetest.dll and urlblast.exe are in "pagetest" and the web pieces (all the php) is in "webpagetest".

It's some pretty hairy code with minimal architecture docs at this point so if you are going to be working with it feel free to ping me with any questions or for a higgh-level overview.

Thanks,

-Pat


RE: Problem with video combine with script - endium - 10-29-2010 05:30 AM

Has anyone been able to get this to work? A visual comparison with login?


RE: Problem with video combine with script - pmeenan - 10-29-2010 06:26 AM

I run visual comparisons all the time for logged in tests (logging into AOL Mail for example). As long as you only need to record video for a single step of the transaction it will work fine (logdata 0, logdata 1 in the script around the parts not to record). Where it falls apart is if you need video for multiple steps all in one sequence.

I have an idea for how to make a multi-step sequence work without much change to the code but I haven't had a chance to implement it yet (basically don't stop measuring intil the end of the script is hit). If you do need the multi-step capabilities I can see about getting it done this week.

-Pat