WebPagetest Forums
maxcdn performance? - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: Web Performance (/forumdisplay.php?fid=3)
+--- Forum: Discuss Test Results (/forumdisplay.php?fid=4)
+--- Thread: maxcdn performance? (/showthread.php?tid=372)



maxcdn performance? - Japsen - 09-14-2010 10:13 PM

Hi all,
I have a server located in the Netherlands also targeted at The Netherlands. To reduce load on the server I tried to use MaxCDN for serving static content like images.
I am webpagetesting my site on a regular basis from the Amsterdam Webpagetest.org location. Quite often I get results like this one: http://screencast.com/t/MWYyNDMyNm
The initial connection or TTFB to the CDN sometimes take many seconds.
Here is a graph of my webpagetest.org results for the past days: http://screencast.com/t/YWQ4ZTNiMGE All the high peaks are caused by loading times of static CDN content.
Does anyone else experience this problem? And more important; how can I fix this? Could this be caused by MaxCDN or the load/connection speed of Webpagetest.org itself?
Regards,
Jaap


RE: maxcdn performance? - pmeenan - 09-14-2010 10:21 PM

What does the CPU utilization look like at the time you have the long gaps? What I have seen happen before is for javascript on the page to cause huge delays and if it happens to execute when the browser is making those requests the requests look like they are taking longer than they really are (single-threaded nature of the browsers - the javascript execution is preventing the browser from being able to process the requests).

Have you tried from different test locations? I haven't seen that kind of behavior with MaxCDN in my testing but I haven't done a lot of testing against their Amsterdam agent either.