WebPagetest Forums
Clearing IE cache doesn't give IE plugin tool a clean results - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: Web Performance (/forumdisplay.php?fid=3)
+--- Forum: Discuss Test Results (/forumdisplay.php?fid=4)
+--- Thread: Clearing IE cache doesn't give IE plugin tool a clean results (/showthread.php?tid=738)



Clearing IE cache doesn't give IE plugin tool a clean results - trx - 05-12-2011 01:25 PM

Hello Community,
I am currently using webpagetest IE plugin tool in IE and found that after deleting all the cache/temp files, restarting browser, and running it on a webpage gives limited http requests; wheras if I do a force refresh, there are many http requests to the server.

ex)
1) Clear cache/temp files
2) Close and open IE browser
3) Run tool on a webpage
4) Results in 10 http requests
5) Now if I force refresh/f5 there are 40 http requests

Why do you think that is? Is it NOT grabbing cache from memory or NOT clearing the cache/temp files?

Any feedback is fully appreciated.

Regards,
TRX


RE: Clearing IE cache doesn't give IE plugin tool a clean results - pmeenan - 05-12-2011 11:25 PM

How are you clearing the cache? Best way is to go to about:blank and then clear it from within the browser (and make sure to get everything, files, cookies, history), exit the browser and then re-launch.

I assume the "real" number of requests for the page is closer to 40 than 10, right?


RE: Clearing IE cache doesn't give IE plugin tool a clean results - trx - 05-13-2011 02:14 AM

I've been doing it through the IE browser. So I've tried using the "about:blank" this time prior to removing the cookies/temp files, etc. I restarted and took the same steps.

1) Typed in: http://qaddev.qad.com/
NOTE: I have attached the a.jpg image for this result.

2) Hit f5.
NOTE: I have attached the b.jpg image for this result.

Let me know what you think.

Regards,
TRX


RE: Clearing IE cache doesn't give IE plugin tool a clean results - pmeenan - 05-13-2011 10:24 AM

Is it possible that the site behaves differently when cookies are present? The requests don't look anything alike after the initial redirect.


RE: Clearing IE cache doesn't give IE plugin tool a clean results - trx - 05-17-2011 12:27 PM

No, that is not the case. The weird thing is if I use FF vs. IE hitting the page for the first time, FF shows 200 code response and IE shows 304 code response. Any ideas why this can be happening?

Regards,
TRX


RE: Clearing IE cache doesn't give IE plugin tool a clean results - pmeenan - 05-18-2011 12:26 AM

The only thing that POSSIBLY comes to mind is that somehow the IE cache is locked and IE is having trouble deleting it. You can try running something like this: http://www.evonsoft.com/crap-cleaner.htm to see if it can nuke the cache.


RE: Clearing IE cache doesn't give IE plugin tool a clean results - trx - 05-18-2011 02:52 AM

Thanks! I used CCleaner and it works now. I"m NOT sure why my IE won't clear the local cache, etc.

Regards,
TRX