WebPagetest Forums
HTTPS / Certificate Authority - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Private Instances (/forumdisplay.php?fid=12)
+--- Thread: HTTPS / Certificate Authority (/showthread.php?tid=781)



HTTPS / Certificate Authority - Joe - 05-26-2011 07:06 PM

Hi guys

I'm running a private instance of Webpagetest in our testing environment. I can run successful reports on our internal webpages with HTTP but not HTTPS, however, if I go out through a proxy I can sucessfully test external HTTPS pages.

The problem I believe points to our use of self-signed certs in the testing environment. I'd like to know if a) Webpagetest or Pagetest.exe is compatiible with self-sign/internal certificate authority, and b) if they are, does Pagetest.exe then have it's own certificate store where I can register our internal cert authority?

I hope this is clear. Really need to get this working. I'm aware of the 'ignore ssl errors' check box, but would rather not have to use it.

Many thanks,

Joe


RE: HTTPS / Certificate Authority - pmeenan - 05-26-2011 10:50 PM

One thing that might help is if you add:

use current account=1

to urlblast.ini. It will run the browser as the same user account as is used for urlblast and should use IE however it is configured (including certificate stores, etc). I'm not sure if pagetest.exe will use the certificate stores configured in the OS but I would think that it should (probably best to try testing with IE first).


RE: HTTPS / Certificate Authority - Joe - 05-26-2011 11:31 PM

Patrick, hi!

I've added the line of code you suggested, my urlblast.ini now looks as follows:

[Configuration]
Startup Delay=10
Log File=c:\webpagetest\log.txt
Timeout=120
Use Current Account=1

; where to get work from
Url Files Url=http://192.168.56.53/work/
Location=Test
Location Key=TestKey123


Unfortunately following this change the pagetest still fails with https. I have monitored task manager and found pagetest.exe is still running as user1, perhaps I've written the code incorrectly?

Alternatively, do you know the password for the user1 account? In theory, if I log in as this user and add the local certificate authority I will be successful.

(05-26-2011 10:50 PM)pmeenan Wrote:  One thing that might help is if you add:

use current account=1

to urlblast.ini. It will run the browser as the same user account as is used for urlblast and should use IE however it is configured (including certificate stores, etc). I'm not sure if pagetest.exe will use the certificate stores configured in the OS but I would think that it should (probably best to try testing with IE first).



RE: HTTPS / Certificate Authority - pmeenan - 05-26-2011 11:44 PM

Are you running the latest (2.2) release or are you on an older build? The "use current account" was a very recent addition and wasn't around before 2.2.

The user1 password is 2dialit

Thanks,

-Pat


RE: HTTPS / Certificate Authority - Joe - 05-27-2011 12:00 AM

I now have it working - I needed to import my chain certificate into the local computer container (rather than user) to get around pagetest.exe. running under the User1 account.

Thank you for your time, Pat, you've been most helpful. Wink

(05-26-2011 11:44 PM)pmeenan Wrote:  Are you running the latest (2.2) release or are you on an older build? The "use current account" was a very recent addition and wasn't around before 2.2.

The user1 password is 2dialit

Thanks,

-Pat