Current time: 11-12-2019, 04:43 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
falsy value TTFB in repeat view
09-25-2012, 10:15 PM
Post: #1
falsy value TTFB in repeat view
Hi

I set up WPT monitor, and had alerts with TTFB > 1s . However I have to consider them as false positives as long as I have a repeat view.

Take a look at this test : http://www.webpagetest.org/result/120925...6564/#run1 , first run
- in the first view, I have the page with a decent TTFB, all is right
- in the repeat view, the TTFB is above 1s

Reason is that there is a cache for the HTML page, so it's not requested in the repeat view. The cache is also correctly set for a lot of objects on this page, so the page is displayed in less than a second.
The TTFB is calculated from the TTFB of the first resource that is really requested (an ad here). Because the page spend the first second to display itself from cache (see CPU), the ad is called too late.

So we are in a situation where an optimized page (good cache management) shows bad number (bad TTFB).
Virtually, the TTFB here is 0s because the main HTML is served from the disk. Have you considered just displaying 0 (or "from disk" maybe) for this value, or do you think I should rather adapt myself and consider the TTFB meaningless in the case of a repeat view of a cached page ?

Jean-pierre VINCENT
braincracking.org
Fork of WPT monitor private instance : https://github.com/jpvincent/WPT-server
Find all posts by this user
Quote this message in a reply
09-26-2012, 05:27 AM
Post: #2
RE: falsy value TTFB in repeat view
I think it's worth implementing a fix on my side where I recognize pages served from cache but that may not always be available - I'll have to see what we can do there (since we usually watch network traffic).
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)