Current time: 09-18-2020, 06:33 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
bad TTFB - need help
12-07-2012, 09:12 AM
Post: #4
RE: bad TTFB - need help
There are two things that are slowing the site up. As @andydavies says, grunt/configuration of the server is the major one... look at the TTFB for the first entry on the waterfall. That's an indication of how long it took to build the html of the page. At over 10 seconds, that's in the huuuge category!

This can be caused by an under-resourced server, poor tuning and / or poor quality code. Finding the right server hosting and sizing the package appropriately will address the first 2, and hopefully you can then find out how fast the coding is.

The second thing that concerns me is the 4MB page size. That's rather big.According to the results posted, resampling images could reduce that by almost 1MB, which will help, although it is still a big page.

The other thing that may help is that I think that Joomla! has a slashdot mode, where it just delivers a pre-created static copy of the page. This may be helpful if your site doesn't change that often...
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
bad TTFB - need help - anne var - 12-06-2012, 03:12 AM
RE: bad TTFB - need help - andydavies - 12-06-2012, 09:08 PM
RE: bad TTFB - need help - anne var - 12-07-2012, 01:30 AM
RE: bad TTFB - need help - GreenGecko - 12-07-2012 09:12 AM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)