MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
Difficulties with Hyper-V clients
Current time: 12-06-2020, 04:13 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Difficulties with Hyper-V clients
08-16-2013, 06:15 PM
Post: #1
Difficulties with Hyper-V clients
Hi Patrick / forum members,

For some time, I've had a working private instance based on two VMs hosted on VMWare. Both were based on Windows 7 (32-bit), one with WAMP as the web server and the other as the client. These have worked well.

The company that I work for (www.trustiv.co.uk) is keen to host a public test location for you in Manchester, UK. We recently invested in some Windows servers running Server 2012 with Hyper-V. This allows us to build virtual machines which we can then switch from private (internal) to public (Internet-facing) networks. I'm currently doing a proof of concept on our private network to get WebPageTest working internally before I create agents on the same platform that you could use for one of your test locations.

Unfortunately, although I've had this working on VMWare before; I'm struggling to get the same configuration working on Windows Server 2012 Hyper-V. Is this a known problem for WebPageTest or have I missed something obvious?

My configuration
VM Host platform - Windows Server 2012 Data Center Edition
Web Server - Ubuntu 12.04 LTS, Apache2, PHP5
WPT client - Windows 7 (32-bit), Chrome+Firefox (WPT), IE9 (urlBlast)

   

.ini files
locations.ini
Code:
[locations]
1=Manchester
default=Manchester

[Manchester]
1=M247_IE
2=M247_Chrome_FF
label=Manchester
connectivity=LAN
lat=53.461507
lng=-2.324599

[M247_IE]
browser=IE 9
latency=0
label="IE 9"

[M247_Chrome_FF]
browser=Chrome,Firefox
label="Manchester"

wptdriver.ini
[WebPagetest]
Code:
url=http://xx.xx.xx.xx/
location=M247_Chrome_FF
software=http://www.webpagetest.org/installers/software.dat

[Chrome]
exe="C:\Program Files\Google\Chrome\Application\chrome.exe"
options='--load-extension="%WPTDIR%\extension" --user-data-dir="%PROFILE%" --no-proxy-server'

[Firefox]
exe="C:\Program Files\Mozilla Firefox\firefox.exe"
options='-profile "%PROFILE%" -no-remote'
template=firefox

urlBlast.ini
Code:
[Configuration]
Startup Delay=30
Log File=c:\webpagetest\agent\urlblast
Timeout=120
use current account=1

; Where to get work from
Url Files Url=http://xx.xx.xx.xx/work/
Location=M247_IE
;Location Key=TestKey123

Observed behaviour
The web server seems to be correctly configured. As well as the system health page looking OK (http://xx.xx.xx.xx/install), the normal webpage is visible and I can see the expected agents (FF, IE and Chrome) in the dropdown box.

When I initiate a test using either URLBlast (IE) or WPTDriver (FF or Chrome), I can see the relevant browser open but the browser never receives any page content and after several minutes my test completes with the error message "The test completed but there were no successful results."

If I observe the behaviour of the browser via an RDP session or Hyper-V console session, I see the relevant browser open with "127.0.0.1:8888/blank.html" in the address bar.
   

The browser never downloads any content and in the case of Chrome I see a plugin error after 60 seconds or so.
   

After a second browser crash the WebPageTest error "no successful results" appears.
   

I've tried adding the "connectivity=LAN" switch in my locations.ini but this didn't help. I've also re-installed the dummynet driver several times since both of these solutions seem to have helped other users on this forum.

Now I'm getting stuck....Have I done something wrong in my config, or could this be a problem related to the use of Hyper-V as a virtualisation platform rather than VMWare (which I've used successfully) or AWS (which I know is widely used by others)?

It would be great to have any feedback or insights from anybody who uses this forum, particularly if they have experience of using WebPageTest with Hyper-V.
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
Difficulties with Hyper-V clients - RichardBishop - 08-16-2013 06:15 PM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)