MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
Stumped on Start Render Time Difference
Current time: 10-21-2020, 09:16 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Stumped on Start Render Time Difference
02-05-2014, 06:00 AM
Post: #1
Stumped on Start Render Time Difference
Greetings,

First, I want to thank Patrick and the team at WPT for providing this amazing resource. Aside from an (unnamed) application performance monitoring tool, this site (including the forums) have been an invaluable resource to us.

We have been working pretty hard on the performance of our site over the past year, trying to employ every "best practice": CDN, async JS/dependencies, nginx, caching, etc. We have every page on the site pre-warmed.

We've hit a plateau troubleshooting the differences between Start Render render times from different parts of the world.

The TTFB is nearly identical (obviously, slightly different from geography), but the there is nearly a ~1.0 s difference between a SR render time from Dulles, vs. Tokyo or Geneva. Our server is based in Oregon:

eg.

Dulles:

Load Time First Byte Start Render
2.736s 0.317s 0.679s

Tokyo:

Load Time First Byte Start Render
4.814s 0.456s 1.765s

Geneva:

Load Time First Byte Start Render
4.664s 0.484s 1.767s


The CDN seems to perform *roughly* the same around the world, so it doesn't seem like a difference in downloading of content. We have some third-party files referenced - eg. G +1, FB - but they are all async.

Maybe this difference is something obvious, but I appreciate any insight. :)

Thanks in advance,
Jay
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
Stumped on Start Render Time Difference - mcsquared - 02-05-2014 06:00 AM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)