The following warnings occurred:
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 802 - File: showthread.php PHP 7.2.19-0ubuntu0.18.04.2 (Linux)
File Line Function
/showthread.php 802 errorHandler->error



Current time: 10-19-2019, 03:52 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
2.14 upgrade/sqlite assistance
05-17-2014, 07:40 AM
Post: #1
2.14 upgrade/sqlite assistance
I wonder if someone has run into this issue:

2.12 install - Test History worked perfectly (all other functions work)
2.14 update - Test History php list is empty (all other functions work)

2.14 Files were downloaded from the 2.14 doc link - not git. Overlayed the existing www install. Updated "settings" and restarted. Only the 1 function fails.

I ended up debugging the "testlog.php" -> getLabel (common_lib.inc) function which makes a SQLite3 call. This is dying as I don't have a ./dat/labels.db.

sqlite> .databases
seq name file
--- --------------- ----------------------------------------------------------
0 main
1 temp


1) What creates the "sqlite3" database elements? Did I miss something in the install/upgrade?
2) In reviewing the downloaded 2.14.zip file (download via the documentation link) I do not see the "viewsqlite.php", yet in git I see it is packaged in the 2.14 release (in documentation and via git clone). Is that intentional?

Any ideas on how to get the sqlite db and Test History functionality back on track?

Thanks in advance
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
2.14 upgrade/sqlite assistance - jharalson - 05-17-2014 07:40 AM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)