MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
Script works locally, not on agent
Current time: 08-06-2020, 08:04 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Script works locally, not on agent
09-25-2014, 08:19 AM
Post: #1
Script works locally, not on agent
I am struggling with a script that works in the local desktop plugin (as downloaded from https://webpagetest.googlecode.com/files...st_325.msi) but fails when i submit it through our private instance UI (it doesn't get through the login part). I'm manually testing the script on one of our agents! So running it manually on the agent works, but running it through UI doesn't ... whatup?

Script:


logData 0
navigate https://www.godaddy.com
clickAndWait innerText=Sign In
setValue id=loginname <masked>
setValue id=password <masked>
submitForm id=loginForm
logData 1
navigate https://app7.websitetonight.com/designer...etid=en-US


Notes:
- The part before logData 1 is just to login and set a session cookie, auth token, etc.
- i took pagetest.dll from the latest agent (v2.14.0.378) and copied it over the 325 version that came with the above mentioned download
- I have tried 'exec' and 'execAndWait' in place of the 'setValue' and 'submitForm' commands but all fail

Could this have anything to do with the format of the script? TABs vs. spaces? What am i missing?

Any help would be much appreciated!
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
Script works locally, not on agent - mverkerk - 09-25-2014 08:19 AM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)