MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
Clueless on high TTFB
Current time: 03-07-2021, 10:35 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Clueless on high TTFB
08-03-2015, 12:27 PM
Post: #1
Clueless on high TTFB
I've upgraded to a 2gb RAM linode with 2CPU's and still experiencing high TTFB. Hosted on Linode Tokyo VPS. I also have setup a new VPS with Linode, also in Tokyo hoping that would change things. No luck so far.

My Setup:
PHP 5.5.9-1ubuntu4.9 (cli)
Apache/2.4.7
mysql Ver 14.14 Distrib 5.5.43,
I run ubuntu 14.04LTS of 2gb ram.
2x 2800 MHz Intel® Celeron® M processor 1.50GHz

Test results of 5sec+ ttfb of 3 or 4 different websites:
http://www.webpagetest.org/result/150803...1/details/
http://www.webpagetest.org/result/150803...1/details/
http://www.webpagetest.org/result/150802...1/details/
http://www.webpagetest.org/result/150802...1/details/
http://www.webpagetest.org/result/150802_QW_EQ8/
http://www.webpagetest.org/result/150802...1/details/
http://www.webpagetest.org/result/150802...1/details/
http://www.webpagetest.org/result/150802...1/details/

Test results on the same VPS always with less than 2sec ttfb:
http://www.webpagetest.org/result/150803_G3_3E4/

This is what surprises me - I have 5 websites that all have high TTFB but there's one website that always has relatively fast TTFB. I have tried different themes, fresh wordpress installs and all 5 seem to result in high TTFB.
W3Cache is activated on all websites and have same configuration as the fast TTFB website. Again, that fast TTFB website is hosted on the same VPS


Apache and PHP setup:
I have turned on PHP cache by:
/etc/php5/apache2/php.ini
Code:
;opcache.enable=0
to
opcache.enable=1
$ php5enmod opcache
$ service apache2 restart

Code:
KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 5
HostnameLookups Off
<IfModule mpm_prefork_module>
    StartServers          4
    MinSpareServers       12
    MaxSpareServers      24
    MaxClients          30
    MaxRequestsPerChild   3000
</IfModule>
<IfModule mpm_worker_module>
    StartServers          2
    MinSpareThreads      25
    MaxSpareThreads      75
    ThreadLimit          64
    ThreadsPerChild      25
    MaxClients          150
    MaxRequestsPerChild   0
</IfModule>
<IfModule mpm_event_module>
    StartServers          2
    MaxClients          150
    MinSpareThreads      25
    MaxSpareThreads      75
    ThreadLimit          64
    ThreadsPerChild      25
    MaxRequestsPerChild   0
</IfModule>

I have started several forum posts in the past months on other forums without any luck:
https://forum.linode.com/viewtopic.php?f=10&t=12053
http://ubuntuforums.org/showthread.php?t...st13320342

Many thanks
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
Clueless on high TTFB - Sp0cK - 08-03-2015 12:27 PM
RE: Clueless on high TTFB - pmeenan - 08-04-2015, 12:26 AM
RE: Clueless on high TTFB - Sp0cK - 08-04-2015, 12:53 AM
RE: Clueless on high TTFB - GreenGecko - 08-10-2015, 09:15 AM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)