MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
Issues running iOS devices
Current time: 08-05-2020, 12:56 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Issues running iOS devices
12-02-2015, 11:03 AM (This post was last modified: 12-03-2015 05:24 AM by waem445.)
Post: #1
Issues running iOS devices
I have several iOS devices that I'm trying to run on a private instance, and each of them has a different issue

I have followed the instructions for iOS mobile agent and have jailbroken my devices and installed node on my mac machine

this is how I'm starting the mobile agent:

./wptdriver.sh -s http://webpagetest.mydomain.com -l Local-iPadAir2 -m info -b ios:<40 character string> --processvideo yes

I'm able to see this device in my under http://webpagetest.mydomain.com/install as connected and am able to trigger the test on the device.


Ipad-2 - jailbroken iOS 8.3
I'm unable to capture any video or save response bodies.
but I'm able to see the film strip.

However, the console output throws following error:

Quote:I Dec_01_16:37:06.331 browser_ios.js:58 new BrowserIos : BrowserIos({"cmd":"run","runNumber":2,"isCacheWarm":true,"exitWhenDone":true,"timeout":120000,"runTempDir":"runtmp/<40 character string>","workDir":"work/<40 character string>","flags":{"deviceSerial":"<40 character string>","serverUrl":"http://webpagetest.mydomain.com","iosDevImageDir":"/Users/testUser/Code/wpt/agent/js/lib/ios/DeviceSupport","iosVideoDir":"/Users/testUser/Code/wpt/agent/js/lib/ios/video","browser":"browser_ios.BrowserIos","iosSshProxyDir":"/Users/testUser/Code/wpt/agent/js/lib/ios/usbmux_python_client","iosUrlOpenerApp":"/Users/testUser/Code/wpt/agent/js/lib/ios/openURL/openURL*.ipa","processvideo":"yes","location":"Local-iPadAir2","captureDir":"/Users/testUser/Code/wpt/agent/js/lib/capture","iosIDeviceDir":"/Users/testUser/Code/wpt/agent/js/lib/ios/idevice/Darwin x86_64"},"task":{"Test ID":"151202_6F_b9a127e1494414dd636c26a59a8866eb","url":"http://www.apple.com","Capture Video":1,"runs":2,"browser":"iPadAir2","bodies":1,"orientation":"default","hostsFile":"127.0.0.1 localhost\n"}})
.
I Dec_01_16:37:08.040 process_utils.js:365 unknown : Spawning: /Users/testUser/Code/wpt/agent/js/lib/ios/video/xrecord -q -d -f -i <40 character string> -o runtmp/<40 character string>/video.mp4
E Dec_01_16:37:10.783 process_utils.js:371 Socket.<anonymous> : /Users/testUser/Code/wpt/agent/js/lib/ios/video/xrecord STDERR: 2015-12-01 16:37:10.783 xrecord[14202:175640] Starting capture....
E Dec_01_16:37:14.565 process_utils.js:371 Socket.<anonymous> : /Users/testUser/Code/wpt/agent/js/lib/ios/video/xrecord STDERR: 2015-12-01 16:37:14.564 xrecord[14202:175640] Recording started. Hit ctrl-C to stop.
E Dec_01_16:37:14.706 process_utils.js:371 Socket.<anonymous> : /Users/testUser/Code/wpt/agent/js/lib/ios/video/xrecord STDERR: [16:37:14.706] vtDecompressionDuctDecodeSingleFrame signalled err=-8969 (err) (VTVideoDecoderDecodeFrame returned error) at /SourceCache/CoreMedia_frameworks/CoreMedia-1562.238/Sources/VideoToolbox/VTDecompressionSession.c line 3241
E Dec_01_16:37:14.709 process_utils.js:371 Socket.<anonymous> : /Users/testUser/Code/wpt/agent/js/lib/ios/video/xrecord STDERR: [16:37:14.710] vtDecompressionDuctDecodeSingleFrame signalled err=-8969 (err) (VTVideoDecoderDecodeFrame returned error) at /SourceCache/CoreMedia_frameworks/CoreMedia-1562.238/Sources/VideoToolbox/VTDecompressionSession.c line 3241
E Dec_01_16:37:14.710 process_utils.js:371 Socket.<anonymous> : /Users/testUser/Code/wpt/agent/js/lib/ios/video/xrecord STDERR: [16:37:14.711] vtDecompressionDuctDecodeSingleFrame signalled err=-8969 (err) (VTVideoDecoderDecodeFrame returned error) at /SourceCache/CoreMedia_frameworks/CoreMedia-1562.238/Sources/VideoToolbox/VTDecompressionSession.c line 3241
I Dec_01_16:37:14.726 process_utils.js:365 unknown : Spawning: '/Users/testUser/Code/wpt/agent/js/lib/ios/idevice/Darwin x86_64/ios_webkit_debug_proxy' -c <40 character string>:5422
E Dec_01_16:37:14.763 process_utils.js:371 Socket.<anonymous> : /Users/testUser/Code/wpt/agent/js/lib/ios/video/xrecord STDERR: [16:37:14.764] vtDecompressionDuctDecodeSingleFrame signalled err=-8969 (err) (VTVideoDecoderDecodeFrame returned error) at /SourceCache/CoreMedia_frameworks/CoreMedia-1562.238/Sources/VideoToolbox/VTDecompressionSession.c line 3241
E Dec_01_16:37:14.785 process_utils.js:371 Socket.<anonymous> : /Users/testUser/Code/wpt/agent/js/lib/ios/video/xrecord STDERR: [16:37:14.786] vtDecompressionDuctDecodeSingleFrame signalled err=-8969 (err) (VTVideoDecoderDecodeFrame returned error) at /SourceCache/CoreMedia_frameworks/CoreMedia-1562.238/Sources/VideoToolbox/VTDecompressionSession.c line 3241
E Dec_01_16:37:14.800 process_utils.js:371 Socket.<anonymous> : /Users/testUser/Code/wpt/agent/js/lib/ios/video/xrecord STDERR: [16:37:14.799] vtDecompressionDuctDecodeSingleFrame signalled err=-8969 (err) (VTVideoDecoderDecodeFrame returned error) at /SourceCache/CoreMedia_frameworks/CoreMedia-1562.238/Sources/VideoToolbox/VTDecompressionSession.c line 3241
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
Issues running iOS devices - waem445 - 12-02-2015 11:03 AM
RE: Issues running iOS devices - pmeenan - 12-03-2015, 12:51 AM
RE: Issues running iOS devices - waem445 - 12-03-2015, 10:08 AM
RE: Issues running iOS devices - pmeenan - 12-08-2015, 11:28 PM
RE: Issues running iOS devices - waem445 - 12-10-2015, 07:10 AM
RE: Issues running iOS devices - pmeenan - 12-16-2015, 02:16 AM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)