Current time: 08-07-2020, 05:23 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
WPTAgent Not Run
03-19-2018, 09:01 PM (This post was last modified: 03-19-2018 09:16 PM by eder92esf.)
Post: #3
RE: WPTAgent Not Run
(03-16-2018 02:37 AM)ch604 Wrote:  youll need to set up locations.ini under your the master to define a name for your agent's location. check the samples in the 'settings' folder for ideas of what to place there. the default is sometimes ok.

once the locations.ini is set up, you will need to run some additional flags with wptagent.py, something along the lines of:

Code:
python wptagent.py -vv  --server http://127.0.0.1/work/ --location
my_test_loc --log wptagent.log

if you let this run, your agent will be running. i recommend starting in screen (screen -S wptagent) and then running the command, then pressing ctrl+a+d to detatch and let it run in the background (see the screen man page for more details).

Thank you very much for your response.

I modified the locations.ini file and made the following changes to test:

Code:
[locations]
1 = Test_loc
2 = Public_Dulles
3 = USA
default = USA

[USA]
1 = PageTest
label = "USA - Chrome, Firefox"
group = North America

[PageTest]
browser = Chrome, Firefox
label = "San Francisco, CA - Chrome, Firefox"
relayServer = "http://127.0.0.1"
; relayKey = Test123
relayLocation = SanFrancisco

and I ran the wptagent:

Code:
python wptagent.py -vv --server http://127.0.0.1/work/ --location PageTest --log wptagent.log

which generated the following output in the terminal:

fatal: Not a git repository (or any of the parent directories): .git
Python 2.7.12
Modern traceroute for Linux, version 2.0.21
Copyright © 2008 Dmitry Butskoy, License: GPL v2 or any later
RTNETLINK answers: No such file or directory
Running agent, hit Ctrl + C to exit

In the webpagetest interface I tried to run a test by passing the url http://www.google.com and I got the error:

Error submitting url for testing

When checking in http: // {server} / install the agents are not connected. What do I need to do to connect them?

Note: The wepagetest is in /var/www/webpagetest and the wptagent is in /home/{user}/wptagent
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
WPTAgent Not Run - eder92esf - 03-14-2018, 05:42 AM
RE: WPTAgent Not Run - ch604 - 03-16-2018, 02:37 AM
RE: WPTAgent Not Run - eder92esf - 03-19-2018 09:01 PM
RE: WPTAgent Not Run - ch604 - 03-20-2018, 01:12 AM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)