Current time: 12-15-2017, 10:30 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
code showing error Relay: Invalid API Key
02-10-2012, 12:44 AM
Post: #1
code showing error Relay: Invalid API Key
hi,

i am sending my different datas used as follows,

locations.ini:

[locations]
1=Test_loc
2=Public_Dulles
default=Test_loc

;
; These are the top-level locations that are listed in the location dropdown
; Each one points to one or more browser configurations
;

[Test_loc]
1=IE
2=Test
label=Test Location

[Public_Dulles]
1=WPT_Dulles_IE8
label="WebPagetest.org - Dulles, VA"

;
; Tese are the browser-specific configurations that match the configurations
; defined in the top-level locations. Each one of these MUST match the location
; name configured on the test agent (urlblast.ini or wptdriver.ini)
;

[IE]
browser=IE 8
latency=0
label="Test Location - IE 8"
;browserExe=pagetest.exe
;browserExe="C:\Program Files\Internet Explorer\iexplore.exe"
key=TestKey123

;
; For a wptdriver configuration (chrome, firefox), the browser labels here
; MUST match the labels used in wptdriver.ini
;

[Test]
browser=Chrome,Firefox
label="Test Location"

;
; This is an exaple of a "remote" configuration where tests can be proxied to a remote
; webpagetest instance. The test will be run by the remote server but the results
; will be downloaded to the local server and deleted from the remote agent
;
; Each location that you want to use from the remote server needs to be configured
; individually on the local configuration (location names do not need to match)
;
; To use the public webpagetest.org instance you will need an API key
;

[WPT_Dulles_IE8]
browser=IE 8
label="WebPagetest.org Dulles, VA - IE8"
relayServer="http://www.webpagetest.org/"
relayKey=<your API key>
;relayKey=<TestKey123>
;relayKey=<input class="start_test" type="submit" value="" name="submit">
relayLocation=Dulles_IE8

settings.in:
[settings]
product=WebPagetest
contact=admin@my.email.com
optLinks=0
maxruns=10
countTests=1
allowPrivate=0

; Comment out the publishTo if you do not want to be able to upload your
; results to the public instance (this is useful for sharing internal tests
; with external users)

;publishTo=www.webpagetest.org

;Uncomment map=1 if you want to enable the map-based picker
;map=1

; test options available
enableSNS=0
enableVideo=1

; disable gzip compressing the result text files
;nogzip=1

;directory to archive test files (must include trailing slash)
;archive_dir=/data/archive/
;showslow beacon
showslow=http://www.showslow.com

; image quality (defaults to 30)
iq=75
;save png full-resolution screen shots
;pngss=1

wptdriver.ini

[WebPagetest]
url=http://localhost/
location=Test
browser=Firefox
key=TestKey123
debug=1

[chrome]
; exe="C:\Documents and Settings\ciluser\Local Settings\Application Data\Google\Chrome\Application\chrome.exe"
exe="C:\Documents and Settings\Administrator\Local Settings\Application Data\Google\Chrome\Application\chrome.exe"
options='--load-extension="%WPTDIR%\extension" --user-data-dir="%PROFILE%" --new-window --no-proxy-server --no-first-run --no-default-browser-check --enable-experimental-extension-apis'

[Firefox]
exe="C:\Program Files\Mozilla Firefox\firefox.exe"
options='-profile "%PROFILE%" -no-remote'
template=firefox


urlblast.ini:
[Configuration]
Startup Delay=30
Log File=c:\webpagetest\agent\log\
Timeout=120
use current account=1
;debug=1

; Where to get work from
;Url Files Url=http://127.0.0.1/
Url Files Url=http://localhost/webpagetest/
Location=IE
Location Key=TestKey123

and the rest of files are as default..
and my log file is showing as:

2012/02/09 19:47:55 -1 0 1 0 0 URLBlast Started
2012/02/09 19:47:55 -1 0 1 4 0 CPU String Intel® Core™2 CPU 4300 @ 1.80GHz
2012/02/09 19:47:55 -1 0 1 5 1798 CPU MHz
2012/02/09 19:47:55 -1 0 1 6 599 Total RAM (MB)
2012/02/09 19:47:55 -1 0 1 7 10228 Disk Size (MB)
2012/02/09 19:47:55 -1 0 1 8 181 Disk Free (MB)
2012/02/09 19:47:55 -1 0 1 9 5 OS Version Windows XP Service Pack 2 (5.1.2600 SP 2.0 Suite 0x00000100 Product 1)
2012/02/09 19:47:55 -1 0 1 10 0 Computer Name PERFORMANCE
2012/02/09 19:47:55 -1 0 1 19 0 Info Screen: 1024 x 768 - 32 bpp
2012/02/09 19:47:55 -1 0 1 11 8 IE Version 8.0.6001.18702
2012/02/09 19:47:55 -1 0 1 12 304 URLBlast Version 2.2.0.304


and the error is showing as Relay: Invalid API Key when i am starting the test with google and using browser IE * and firefox..
could u pls solve the issue for me...
with regards,
Venkatesh.A
Find all posts by this user
Quote this message in a reply
02-10-2012, 11:57 PM
Post: #2
RE: code showing error Relay: Invalid API Key
Delete the keys.ini in your settings folder. You usually don't need it for a private instance.
Visit this user's website Find all posts by this user
Quote this message in a reply
02-13-2012, 07:17 PM
Post: #3
RE: code showing error Relay: Invalid API Key
hi patrick,
thanks for the reply..and it worked for an instance..i mean i am unable run it on other browsers like firefox and chrome installed on the same machine and my doubt is that i also want to run it different locations like Dulles,VA etc. for that i need there API keys ..pls forward me the API keys for different locations of world(like 4 to 5 places) and mention the necessary changes to be made,so that i can test my sample application from various locations using different browsers...and thank you once again...
Venkatesh.A
Find all posts by this user
Quote this message in a reply
02-14-2012, 12:32 AM
Post: #4
RE: code showing error Relay: Invalid API Key
To use the public instance you will need keys - email me at pmeenan@webpagetest.org and I can provide one. The same key works for all locations but you will be limited in the number of tests that you can submit to it per day.

Thanks,

-Pat
Visit this user's website Find all posts by this user
Quote this message in a reply
03-19-2013, 06:28 AM
Post: #5
RE: code showing error Relay: Invalid API Key
(02-14-2012 12:32 AM)pmeenan Wrote:  To use the public instance you will need keys - email me at pmeenan@webpagetest.org and I can provide one. The same key works for all locations but you will be limited in the number of tests that you can submit to it per day.

Thanks,

-Pat

Hi Patrick,

As I try to test instances from a public location, I'm unable to and receive the following error messages - Relay: Invalid API Key. Would you be kind to provide me with API key?

Thank you,

Kevin
Find all posts by this user
Quote this message in a reply
03-20-2013, 01:29 AM
Post: #6
RE: code showing error Relay: Invalid API Key
Yes, if you email me like I mentioned :-)
Visit this user's website Find all posts by this user
Quote this message in a reply
10-22-2014, 07:17 AM
Post: #7
RE: code showing error Relay: Invalid API Key
How/Where do you obtain the relayKey for:

[WPT_Dulles_IE8]
browser=IE 8
label="WebPagetest.org Dulles, VA - IE8"
relayServer="http://www.webpagetest.org/"
relayKey=<your API key>
;relayKey=<TestKey123>
;relayKey=<input class="start_test" type="submit" value="" name="submit">
relayLocation=Dulles_IE8
Find all posts by this user
Quote this message in a reply
10-24-2014, 03:22 AM
Post: #8
RE: code showing error Relay: Invalid API Key
Read just a couple of posts up in the thread: http://www.webpagetest.org/forums/showth...0#pid16210
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)