Current time: 08-04-2020, 01:50 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
WPT 2.5 Chrome-Firefox http code 404
02-20-2012, 06:16 AM
Post: #1
WPT 2.5 Chrome-Firefox http code 404
Hi,
I successfully managed to run wpt on Windows 2008 r2 server using IE9.
Problem is that I can't make it work with Chrome - Firefox. Browser doesn't open. I can see in my server access_log the following:
(ip)xxx.xxx.xxx.xxx - - [19/Feb/2012:20:39:16 +0200] "GET /webpagetest/work/getwork.php?location=Test_IE&key=&pc=SPEEDTESTER&ver=300 HTTP/1.1" 200 344 "-" "urlBlast"

(ip)xxx.xxx.xxx.xxx - - [19/Feb/2012:20:39:17 +0200] "GET /webpagetest/work/work/getwork.php?location=Test_Chrome&software=wpt&ver=38&pc=SPEEDTESTER&freedisk=11.470 HTTP/1.1" 404 487 "-" "WebPagetest Driver"

I suppose that HTTP/1.1 200 for urlblast is ok, that is why IE is working.
What about HTTP/1.1 404 for wptdriver?
wptdriver.ini is:
---------------------------------------------------------------
[WebPagetest]
url=http://www.checkdomains.co/webpagetest/work/
location=Test_Chrome
browser=chrome
;key=TestKey123
;debug=1

[chrome]
exe="C:\Users\Administrator\AppData\Local\Google\Chrome\Application\chrome.exe"
options='--load-extension="%WPTDIR%\extension" --user-data-dir="%PROFILE%" --new-window --no-proxy-server --no-first-run --no-default-browser-check --enable-experimental-extension-apis'

[Firefox]
exe="C:\Program Files (x86)\Mozilla Firefox\firefox.exe"
options='-profile "%PROFILE%" -no-remote'
template=firefox
----------------------------------------------------------------------

paths are tested ok.
Do I have to replace %WPTDIR% and %PROFILE% with something?
I have to add that in /work/jobs/Test_Chrome directory, after a test attempt, there is a file created named: 120219_77_C1.url
containing the following:
Test ID=120219_77_C1
url=http://www.........com (here is the testing url ok)
fvonly=1
web10=1
ignoreSSL=1
runs=1
imageQuality=75

(I have made the last agent update.)
I would appreciate any help. Thank you.
Find all posts by this user
Quote this message in a reply
02-21-2012, 01:47 AM
Post: #2
RE: WPT 2.5 Chrome-Firefox http code 404
wptdriver.ini neets to NOT have the /work/ directory in the path - it is added automatically by the code (sorry for the inconsistency, was trying to move to a cleaner config).

As a side note, WPT doesn't do very well not being at the root of a domain - a ot of the paths are absolute and the UI will probably break.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)