Current time: 10-20-2019, 04:22 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Need Help with Script Error on Screenshot
03-11-2012, 01:33 PM
Post: #1
Need Help with Script Error on Screenshot
Hello,

I've used webpagetest.org a million times and have never seen anything like what I've seen today. My site's loading time has slowed down by several seconds and the screenshot from the text shows that there's an error box of some sort, though I can't really tell what the error is. I've had my host look into things and I've racked my brain trying to figure out how to fix this error, but I'm still coming up empty. Huh

http://www.webpagetest.org/result/120311_3G_3HNVZ/

Can anyone shed some light on this situation for me? Thanks a bunch for your help with this.
Find all posts by this user
Quote this message in a reply
03-13-2012, 03:53 AM
Post: #2
RE: Need Help with Script Error on Screenshot
The error looks to be the slow script warning (a script on this page is causing something or other to load slowly). You can try running a test on one of the dynatrace agents and capture a profile of the code execution.
Visit this user's website Find all posts by this user
Quote this message in a reply
03-13-2012, 04:01 AM
Post: #3
RE: Need Help with Script Error on Screenshot
Thanks so much for your suggestion Patrick! I'd love to give it a try, but unfortunately, I don't know how to do as you suggested...please forgive my newbieness! Smile Would you mind telling me the steps I should follow? Thanks a bunch!
Find all posts by this user
Quote this message in a reply
03-13-2012, 04:11 AM
Post: #4
RE: Need Help with Script Error on Screenshot
I'll see if I can find something running a profiler run but my guess is that it is related to the toolbar javascript that is loading from http://cdn.wibiya.com/Toolbars/dir_0301/...65a6d7f.js since the huge gap happens right after the javascript loads.
Visit this user's website Find all posts by this user
Quote this message in a reply
03-13-2012, 05:07 AM
Post: #5
RE: Need Help with Script Error on Screenshot
Can you try disabling Cloudflare's rocket loader temporarily? If the problem doesn't go away then it will be a lot easier to track down (if it does go away then CloudFlare is really responsive and it would be worth pinging them to make them aware of it).

Thanks,

-Pat
Visit this user's website Find all posts by this user
Quote this message in a reply
03-16-2012, 04:21 AM
Post: #6
RE: Need Help with Script Error on Screenshot
Thanks for the suggestion Pat. I tried disabling Rocket Loader and kept receiving the same script loading error. The thing is, that the page I'm running a speed test on never has Rocket Loader enabled, for I have a page rule set up to eliminate it from this particular type of page.

http://www.webpagetest.org/result/120315_7Y_3KJ87/

I also notice that my pages are slower overall in the other browsers, but I only seem to get the script error screen in IE8.

Is there anything else I can do to try to track down the offending script? Thanks so much for all of your help!
Find all posts by this user
Quote this message in a reply
03-17-2012, 12:10 AM
Post: #7
RE: Need Help with Script Error on Screenshot
You can profile the script in Chrome's dev tools or with Dynatrace Ajax Edition. That should bring you to the slow part of the code pretty quickly. The hard part is that you generally need to be a developer to do it Sad If I get a bit of free time I'll see if I can take a look again.
Visit this user's website Find all posts by this user
Quote this message in a reply
03-17-2012, 02:23 AM
Post: #8
RE: Need Help with Script Error on Screenshot
Thanks so much Patrick! I think I figured it out from the tips you sent. There was what appeared to be some malicious script in the footer region of my blog and once I removed it, the site sped back up and the error message went away. Thanks a bunch for all of your help...I really appreciate it! Smile
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)