Current time: 10-28-2020, 11:01 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Slow loading
05-18-2012, 10:41 PM
Post: #1
Slow loading
My site takes more than 7 secs to load - http://www.webpagetest.org/result/120518_Z3_7KG/

Site hosted on dedicated Quad Core 8GB RAM server.

WP Total Cache and MaxCDN is enabled.

Query cache is also enabled in MySQL

My host suggests that since the site more static with less CPU consumption APC is not required and hence not enabled.

I surfed the forum and actioned the MySQL cache and APC measures.

What can I do to reduce the load time ?

Please guide
Find all posts by this user
Quote this message in a reply
05-19-2012, 01:06 AM
Post: #2
RE: Slow loading
Your back-end looks like it is performing fine. It took < 100ms to generate the page (the F for the first byte time is because of the redirect to the www page). Here is a test of the www page directly: http://www.webpagetest.org/result/120518...0419ee447/

There are a bunch of things you can do on the front-end (html/javascript) to make it faster:

Enabling browser caching of your static content should be high up on your list. It will make navigating the site and repeat visits quite a bit faster. If you're using W3 Total Cache you just need to turn on browser caching of css and javascript (and make sure to change the cache control headers to use public and not re-validate).

It looks like you are still serving some CSS from your main domain (and your main domain is set to not allow for keep-alive connections).

If you can, move all of your javascript except for the ads to the end of the HTML. I don't see anything in the UI that needs to load jquery and the rest of the javascript before the HTML is loaded. It looks like you are loading a BUNCH of JQueryUI modules at the end of the html - are those all actually used on the site? The UI looks very static so I'm surprised to see so much javascript getting loaded.

The Digg Digg plugin looks like it is using blocking scripts for all of the social buttons. You should see if there is an update or go back to the author to ask them to use the async versions instead.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)