Current time: 12-13-2019, 11:55 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No request data in FireFox
09-05-2012, 04:29 AM
Post: #1
No request data in FireFox
Hi there,

Just got my private instance up and running (WinXP). IE8 and Chrome 21 are working beautifully. I am having an issue with Firefox 15 where the results do not include any request data or details. Only the CPU utilization and bandwidth are shown.

Anybody have any ideas?

I've downloaded the latest wptupdate.zip and update.zip, but still having the same issue. INI files and screenshot are include.

   

Code:
[locations]
1=Localhost
default=Localhost

;
; These are the top-level locations that are listed in the location dropdown
; Each one points to one or more browser configurations
;

[Localhost]
1=IE
2=wptdriver
label="Bobby's laptop"

;
; Tese are the browser-specific configurations that match the configurations
; defined in the top-level locations.  Each one of these MUST match the location
; name configured on the test agent (urlblast.ini or wptdriver.ini)
;

[IE]
browser=IE 8
latency=0
label="Bobby's laptop - IE 8"
browserExe=pagetest.exe
key=TestKey123

;
; For a wptdriver configuration (chrome, firefox), the browser labels here
; MUST match the labels used in wptdriver.ini
;

[wptdriver]
browser=Chrome,Firefox
label="Bobby's laptop - wptdriver"

Code:
[WebPagetest]
url=http://127.0.0.1
location=wptdriver
;key=TestKey123
;Automatically install and update support software (Flash, Silverlight, etc)
software=http://www.webpagetest.org/installers/software.dat

[Chrome]
exe="C:\Program Files\Google\Chrome\Application\chrome.exe"
options='--load-extension="%WPTDIR%\extension" --user-data-dir="%PROFILE%" --no-proxy-server'
installer=http://www.webpagetest.org/installers/browsers/chrome.dat

[Firefox]
exe="C:\Program Files\Mozilla Firefox\firefox.exe"
options='-profile "%PROFILE%" -no-remote'
installer=http://www.webpagetest.org/installers/browsers/firefox.dat
template=firefox

Thanks,
Bobby
Find all posts by this user
Quote this message in a reply
09-06-2012, 12:01 AM
Post: #2
RE: No request data in FireFox
Try a page other than Google - maybe http://www.yahoo.com

There's a chance that it is forcing https for google and Firefox now has SPDY support (and WPT doesn't decode SPDY directly yet).
Visit this user's website Find all posts by this user
Quote this message in a reply
09-06-2012, 04:02 AM
Post: #3
RE: No request data in FireFox
Thanks for the help Patrick.

Not much better luck with http://www.yahoo.com. The strange thing is it worked 1 time for a repeat view on yahoo, but then every subsequent run (first time or repeat) it reverted back to no data.

Its almost as if it is unable to hook into the browser?

I'll try reinstalling FF and reapplying the wptupdate.
Find all posts by this user
Quote this message in a reply
09-06-2012, 04:11 AM
Post: #4
RE: No request data in FireFox
(09-06-2012 04:02 AM)BobbyAAP Wrote:  Thanks for the help Patrick.

Not much better luck with http://www.yahoo.com. The strange thing is it worked 1 time for a repeat view on yahoo, but then every subsequent run (first time or repeat) it reverted back to no data.

Its almost as if it is unable to hook into the browser?

I'll try reinstalling FF and reapplying the wptupdate.

Just a sanity check, it is a 32-bit Firefox, correct? I'm pretty sure you wouldn't even be getting screen shots if it wasn't hooking (because the screen shot code is part of what gets injected).

I'm pretty sure it's not a version thing either because I have Firefox 15 running on the public instances.

Any chance there is other software running that may be mucking with things or a proxy of some kind?
Visit this user's website Find all posts by this user
Quote this message in a reply
09-07-2012, 02:12 AM
Post: #5
RE: No request data in FireFox
Definitely 32-bit Firefox. No luck with reinstalling wptdriver or FF either.

There is plenty of aggressive anti-virus and monitoring software installed on this machine that I can't disable Sad, so I'll chalk it up to that.

Thanks for the help Pat.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)