Current time: 07-30-2014, 12:45 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
bad TTFB - need help
12-06-2012, 03:12 AM
Post: #1
bad TTFB - need help
Hi,

Here are my results http://www.webpagetest.org/result/121205_JT_FK5/. I get a TTFB of 6 seconds.

I'm running a joomla site with a very bulky template. I have installed jbetolo but it only seems to be compressing some of the files (I have to be careful about the home page, as it seems to mess up the background slider if I don't merge per resource.

There are way too many background images loading and js and I'm not sure why it's not merging them all? I'm just stumped. I would be very grateful if someone could have a look and give me some insight into this?
Find all posts by this user
Quote this message in a reply
12-06-2012, 09:08 PM
Post: #2
RE: bad TTFB - need help
Looks like the long TTFB is down to the server taking a long time to generate and return the page to the client.

It's probably that the DB is slow to respond, do you know how quickly it's replying to queries and how many are needed to build the page?

What sort of hosting are you on?
Visit this user's website Find all posts by this user
Quote this message in a reply
12-07-2012, 01:30 AM
Post: #3
RE: bad TTFB - need help
Hmmm, I'm with Godaddy - shared hosting. This was my first thought too, so I called them and they said all was fine on their end. However, it looks like it probably is the shared hosting that's the culprit. I don't know how quickly or how many queries to the DB are taking place... I will look into this and see if there's anything else I can do (ideas are welcome, I'm not too db savy). This template is fairly bulky (live and learn :\ ). Thanks for your response, maybe I can stop banging my head against the wall with this one.
Find all posts by this user
Quote this message in a reply
12-07-2012, 09:12 AM
Post: #4
RE: bad TTFB - need help
There are two things that are slowing the site up. As @andydavies says, grunt/configuration of the server is the major one... look at the TTFB for the first entry on the waterfall. That's an indication of how long it took to build the html of the page. At over 10 seconds, that's in the huuuge category!

This can be caused by an under-resourced server, poor tuning and / or poor quality code. Finding the right server hosting and sizing the package appropriately will address the first 2, and hopefully you can then find out how fast the coding is.

The second thing that concerns me is the 4MB page size. That's rather big.According to the results posted, resampling images could reduce that by almost 1MB, which will help, although it is still a big page.

The other thing that may help is that I think that Joomla! has a slashdot mode, where it just delivers a pre-created static copy of the page. This may be helpful if your site doesn't change that often...
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)