Current time: 09-01-2014, 11:38 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Site is fast but takes seconds to load last images
01-21-2013, 06:07 AM
Post: #1
Site is fast but takes seconds to load last images
Hi guys I was wondering if someone could explain why the last images on my wesite take so long to start loading. The entire website (without these images) loads in a respectable 1.6 seconds, then it takes a few seconds before it loads the rest?!

Cheers,
Nick

[attachment=252]
Find all posts by this user
Quote this message in a reply
01-23-2013, 02:18 AM
Post: #2
RE: Site is fast but takes seconds to load last images
Hmm, attachment doesn't appear to have made it. Any chance you can link to the actual test result?
Visit this user's website Find all posts by this user
Quote this message in a reply
01-23-2013, 02:28 AM
Post: #3
RE: Site is fast but takes seconds to load last images
Hi Patrick thanks for your reply, just made a fresh one:

http://www.webpagetest.org/result/130122...90b96207a/

That first (12 sec) one is not really representative but it does show the general idea.
Find all posts by this user
Quote this message in a reply
01-23-2013, 02:52 AM
Post: #4
RE: Site is fast but takes seconds to load last images
Looks like general bandwidth constraint (look at the bandwidth line at the bottom). It is downloading them all in parallel and that maxed out the 1.5Mbps.
Visit this user's website Find all posts by this user
Quote this message in a reply
01-23-2013, 04:03 AM (This post was last modified: 01-23-2013 04:28 AM by nmvdvjr.)
Post: #5
RE: Site is fast but takes seconds to load last images
So I tweaked my website to the point that it broke the internet?

THAT'S AWESOME!

Where does this restraint come from though? Could it be the Incapsula CDN service or my hosting company?

This is very interesting

How do I fix this?

Thanks Patrick!

Well, I think this is not an existing problem since the page loads fine, maybe thanks to lazy loading. I love to hear your further opinion on this.
Find all posts by this user
Quote this message in a reply
01-24-2013, 03:17 AM
Post: #6
RE: Site is fast but takes seconds to load last images
You didn't break anything. The default connectivity that WebPagetest uses to test a site is throttled to match a consumer DSL line. Mobile will be slower, cable will be faster - it's all selectable under the advanced settings. It also has nothing to do with the CDN serving the images.

What would actually help most would be to move the javascript to the end of the body but that may be hard to do without breaking your page.
Visit this user's website Find all posts by this user
Quote this message in a reply
02-01-2013, 08:09 PM
Post: #7
RE: Site is fast but takes seconds to load last images
Thanks for your help Patrick!
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)