Current time: 11-22-2019, 08:31 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Chrome malware protection: turn it off
05-01-2013, 11:45 PM (This post was last modified: 05-01-2013 11:58 PM by Nicholas Godfrey.)
Post: #1
Chrome malware protection: turn it off
I'm having trouble with one of my sites with Chrome and its malware protection setting. When I run through webpagetest,

chrome jams up with 100% cpu. After some net investigation I discovered that turning off the phishing and malware setting

fixes this. So I went into the webpagetest profile (under my roaming folder) and changed the setting (launching by hand

with that profile, went to settings, advanced and set it there). this gives good results out of webpagetest but, on the

next run, webpagetest has reset this setting, so my automated CI webpagetest runs don't work.

I also tried changing the profile that webpagetest uses to my own chrome profile (in the options in wptdriver.ini). This

works consistently but the cache doesn't get reset on subsequent webpagetest test runs so all but the first test are

effectively with a cached browser.

I think these problems are caused by my particular site which is in development and has various resources coming from

different internal environments. It must be triggerring some Chrome 'dodgy site' flag. But I want to use chrome in

particular because we need the console output to help improve the site - my devs are going to add some debug info into

there.

I looked up chrome command line settings and tried the '--disable-client-side-phishing-detection' option in wptdriver.ini

but it didn't seem to help. Is there a way to load a set of settings for chrome to use when webpagetest laushes? I could

see this could be useful generally. Are these settings stored somewhere in the chrome profile that I could set with a

script as part of the webpagetest launch process? I did look at files such as 'Loacl state' but haven't worked out a way

that I can control this settings adequately.

Thanks,
Nick


Relating to this, I've seen another issue with my tests that may be related to some of the other options in chrome. I set quite a few 3rd party calls to point to 127.0.0.1 but chrome seems to try and find them. This may be due to the 'use a web service to help resolve navigation errors' setting, which I probably also want to turn off. I've attached a screenshot of the other settings I would like control on.

Nick


Attached File(s) Image(s)
   
Find all posts by this user
Quote this message in a reply
05-03-2013, 01:01 AM
Post: #2
RE: Chrome malware protection: turn it off
If you want to use a different default profile setting you can create a directory under templates (let's call it 'chrome') and copy what you want to use as a default profile into there (clear cache and whatever options you want set). Then in the wptdriver.ini you can just add a template= line like firefox. It will copy your template directory to the empty profile before running the test.
Visit this user's website Find all posts by this user
Quote this message in a reply
05-03-2013, 10:25 PM
Post: #3
RE: Chrome malware protection: turn it off
Thanks, that's really useful to know. I tried it and got further but I seem to have other issues that are causing Chrome to jam up the CPU. I found a site on the net that gives me similar issues so I think there's something installed on my test machine that's causing this. i could run that site ok from the public instance. I'll investigate further.

Nick
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)