Current time: 09-17-2019, 08:14 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Broken video for multiple steps
06-13-2013, 06:37 PM
Post: #1
Broken video for multiple steps
We are running a private instance of webpagetest. Our scripts measure multiple steps without using the combineSteps command since we want to get seperated results for each step.

Unfortunately, our scripts generate broken videos. It seems that the screenshots for the videos are overriden by the next screenshot (of the next step) with the same time. Is there any way to extend webpagetest that a valid video is generated even if we use multiple steps without combining them?

An example test result is stored at http://www.webpagetest.org/result/130613_WZ_CK9/ and the broken video filmstrip is found at http://www.webpagetest.org/video/compare...K9-r:1-c:0

The following script where used to generate this result:
navigate http://www.amazon.de
navigate http://www.ebay.de
navigate http://www.google.de

The resulting video we expect should first show the loading of http://www.amazon.de, then the loading of http://www.ebay.de and finally, the loading of http://www.google.de. But webpagetest generates a video which is a mix of all three pages.
Find all posts by this user
Quote this message in a reply
06-14-2013, 04:17 AM
Post: #2
RE: Broken video for multiple steps
WebPagetest is expecting to measure just one step and doesn't have provisions for collecting data from a bunch of steps in a sequence. That means you can either combineSteps to get a single full sequence or use logData 0/1 to record data from just a single step from a sequence.

It's been on the roadmap to implement full support for gathering all of the data, it just hasn't been a priority.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)