Current time: 10-15-2019, 01:33 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Result changed after not using Cloudflare!?
10-20-2013, 10:50 PM (This post was last modified: 10-20-2013 10:58 PM by robzilla.)
Post: #2
RE: Result changed after not using Cloudflare!?
Quote:HTTP persistent connection, also called HTTP keep-alive, or HTTP connection reuse, is the idea of using a single TCP connection to send and receive multiple HTTP requests/responses, as opposed to opening a new connection for every single request/response pair.
http://en.wikipedia.org/wiki/HTTP_persistent_connection

When you serve your website through CloudFlare, their servers take care of (and control over) all HTTP connections. As such, they can enable features like Keep-Alive, even when your web host does not support it. Now that you disabled CloudFlare, connections are handled directly by your web host, and apparently they have indeed disabled keep-alive.

I'm assuming you are on shared hosting; in that case, there's not much you can do about this. If, however, you are on your own VPS or dedicated server, you can enable keep-alive via your web server's configuration files.

It looks like you're not allowing your pages (i.e. your HTML) to be cached, which is fine (and often makes sense) for dynamic content, but it also means that when you serve your website through CloudFlare, their edge servers will always have to forward the page request to your web host, rather than serving it directly as they would with cached resources such as images, thus adding a bit of processing and latency. This might explain the slightly higher TTFB.
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
RE: Result changed after not using Cloudflare!? - robzilla - 10-20-2013 10:50 PM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)