Current time: 12-13-2017, 03:43 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Test Results not looking good. Need some help please.
12-08-2013, 02:16 AM (This post was last modified: 12-08-2013 02:18 AM by Charlie.)
Post: #21
RE: Test Results not looking good. Need some help please.
I know this thread has gotten a bit off topic, but I would like to show you our before and after results thanks to your help and suggestions. Thank you.

Before: http://www.webpagetest.org/result/131124_N7_S0F/

Now: http://www.webpagetest.org/result/131207_13_MBH/

Just need some help with First Byte Times.
Find all posts by this user
Quote this message in a reply
12-08-2013, 11:27 PM
Post: #22
RE: Test Results not looking good. Need some help please.
Sorry my mind has a tendency to veer off topic.

Besides the Time To First Byte (TTFB) issue you MUST get the CSS and JS sequence correct in the <HEAD>

When I see long times between TTFB and All I have to do in many is go to the Request Details Content Type and find the last text/css or font/eot, take note of the Start Offset, go back to the Waterfall View's Start Render and or First Paint at the Start Offset time and it is obvious these Request Response Content types have delayed the Start Render. An exception is when the text/css or font/eot Content Type comes after Start Render the CPU usage spikes due to a Render Re-Start.
Find all posts by this user
Quote this message in a reply
12-08-2013, 11:35 PM
Post: #23
RE: Test Results not looking good. Need some help please.
Well done! :-)

First-Byte times mostly depend on the complexity of the CMS (or lack of optimization thereof) and the available hardware resources on the server. You'll want to make sure you have an opcode cache installed for PHP, such as APC or OPcache, that your database has proper indexes -- basics which I hope your developer has already implemented. The first step would probably be to install something like New Relic for application performance monitoring, which can help you discover where most of the processing takes places.

I hope you've only temporarily removed the search box...
Find all posts by this user
Quote this message in a reply
12-09-2013, 07:08 AM
Post: #24
RE: Test Results not looking good. Need some help please.
I see that you've imlemented some of the tips you got here that's good.

I'm guessing you website is redirecting from non www to www to avoid duplicate content. If so I would use rel canonical tag that way search enignes index only one version of the page and the redirect disappears for user.

My next sugestion would be to combine all of the extenrla css files in one file and where you can, you can do the same with javascript as long as nothing breaks.

You also have alot of external javascript files in the header, if you really don't need them there you should move them in the footer

And last, you need to figure it out why you index page has such a big TTFB the page itself looks pretty simple, I would exclude that the server is the culprit since all the other resource have a decent TTFB

Good luck
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)