Current time: 11-22-2017, 08:41 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
First Byte & gzip issues
01-02-2014, 12:06 AM
Post: #1
First Byte & gzip issues
Hi,

Specs:
VPS - Ubuntu 13.04 x64
2 CPU Core
4 GB RAM
40 GB SSD
cPanel/WHM
Australia Hosted - Sydney Equinix Data Center

gzip enabled (default compression value 6) and, zlib.output_compression = on

CMS - Wordpress

Test page result:
http://www.webpagetest.org/result/140101_XZ_AVH/

I've managed to wipe around 1.1s from total load time. But, The 1'st Byte seems high. And I'd like to try and reduce this further. Also the compression is reporting an F grade but I have gzip enabled and am using a cache.

Site targets Australian and New Zealand traffic but even from my location, approx 1,000miles from server and running a 20Mbit link, the site is loading way too slow for my liking.

I would appreciate any input or suggestions to help me improve the above, web page speed test, thank you.


Cheers

Dave






Find all posts by this user
Quote this message in a reply
01-03-2014, 05:46 AM
Post: #2
RE: First Byte & gzip issues
The 2.4 second first byte time is killer and not something we can debug from the outside. Since it's a VPS, can you install NewRelic (or something similar)? They have a free offering and a 2-week trial of the full product which should be able to tell you exactly what is slow on the back-end. Otherwise it's going to be a matter of instrumenting the code to isolate the slow bits.

Being a wordpress site, take a look at your plugins and make sure you really need all of them. They tend to like to make a lot of database queries and 9 times out of 10 that's what makes things slow.

It's worth installing the W3 Total Cache plugin and enabling the database and object caches (as well as the page cache if the main page is mostly static), preferably with apc if you can install that as well. That will eliminate the overhead with repeated database calls and can usually eliminate most of the slowness.
Visit this user's website Find all posts by this user
Quote this message in a reply
01-03-2014, 06:51 AM (This post was last modified: 01-03-2014 06:56 AM by ozguy61.)
Post: #3
RE: First Byte & gzip issues
Thanks for heads up and suggestions.

I have another VPS with a different provider, which has 1/3 of the ram and no SSD. I ran the test on a WP site on this other box. It runs exactly the same plugins and site is comparable in size etc. Total load time 1.476s, TTFB 0.593s.

Uses gzip and some other code in htaccess for expired headers and so forth.

As you suggested, I'll install NewRelic and see where I'm at then. But I've been at this for over a week now and if I can't get it figured out soon, I'll just upgrade the VPS at my older host and ditch this new one.

Cheers

Dave
Find all posts by this user
Quote this message in a reply
01-03-2014, 06:53 AM
Post: #4
RE: First Byte & gzip issues
Is the database run on the same host as the web server in both cases?
Visit this user's website Find all posts by this user
Quote this message in a reply
01-04-2014, 05:57 AM (This post was last modified: 01-04-2014 06:02 AM by ozguy61.)
Post: #5
RE: First Byte & gzip issues
The DB is unique for each server.

Anyways, I've thrown in the towel and returned to my old VPS, cause the support guys (2), while friendly, seemed lost and given, I'm also paying for managed, then it's a waste of cash.

Back on the old VPS, I've tweaked some settings and used basic compression. Happy to say I've drastically reduced the slowness:

ttfb: 0.917s (if I can reduce this more I'll be a happy camper)
sr: 1.724s
dc: 2.391s
fl: 2.775s

Once I add a W3TC the site should scream.

Thanks again for your help and sorry to stuff you about.


Cheers

Dave
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)