MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
Slow website; what's your take on this?
Current time: 07-15-2020, 02:44 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Slow website; what's your take on this?
04-01-2014, 02:55 AM
Post: #1
Slow website; what's your take on this?
Hi,

I'm dissatisfied with my website performance, especially the first view time:

Pingdom:
7.21s: http://tools.pingdom.com/fpt/#!/dixuX9/w...ngcode.net
2.25s: http://tools.pingdom.com/fpt/#!/dFt5bX/w...ngcode.net

Webpagetest:
From Amsterdam (as baseline, since the webserver is located in the same county), first views 4.1, 1.5, and 1.6 seconds: http://www.webpagetest.org/result/140329_KC_78M/

From Moscow: first views 6.4, 2.8, and 3.1 seconds: http://www.webpagetest.org/result/140329_YY_707/

From Tokyo: first views 4.7, 1.2, and 1.3 seconds: http://www.webpagetest.org/result/140329_CJ_709/

Pingdom RUM:
These are the average page load times for the last two days according to Pingdom's RUM:

[Image: pingdomRUMdata.png]


* * * *


Because CloudFlare caches content at data centres after being request by a visitor (if it is not already cached), a somewhat higher first view time is expected I guess. But since I've set CloudFlare to cache everything for 1 week (Edge cache expire TTL), I'd would expect that the subsequent load times were much lower, especially since my website is only 290kb big.

After all, in case of the Moscow test, it will probably not take 3 seconds to serve a cached HTML file of that size from CloudFlare's Warsaw data centre to Moscow. So something along the way is probably going wrong.

From my side, I've done already the things that I'm aware of to increase the speed. The WordPress website uses the WP-Super Cache plugin which preloads all webpages into static HTML content. Furthermore, I've removed all redundant plugins, and replaced slow plugins by quicker, more lightweight versions. According to the WordPress P3 performance profiler plugin, the site load time is 0.641 seconds.

If I look at Webpagetest's waterfalls, my novice mind gets the impression that something is wrong with the communication between CloudFlare and the original webserver, since most of the worse performance seems to be due to these two waiting on each other.

I've already asked my hosting provider and CloudFlare themselves why the first view times, and especially the TTFBs, are so high, but so far I've not gotten a clear answer -- though I may have asked the wrong questions.



My question:
Do you guys might have an idea how I can improve the website speed?


Thanks in advance for any insights.

Note: The browser cache is set deliberately to 1 day for now, since I'm working on the layout, so that gives a lower performance grade in the test reports.
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
Slow website; what's your take on this? - JMTC - 04-01-2014 02:55 AM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)