Current time: 12-15-2017, 08:36 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Chrome repeat run is beginning with JS instead of Document
04-24-2014, 05:14 AM
Post: #1
Chrome repeat run is beginning with JS instead of Document
I've been running tests quite a bit and I can't explain why my SSL pages are getting odd results on the second run.

http://www.webpagetest.org/result/140423...ls/cached/

It's only if Chrome too. Firefox for instance runs from the Document as first byte.

Any idea where blame may lay on why it's running oddly?
Find all posts by this user
Quote this message in a reply
04-29-2014, 04:23 AM
Post: #2
RE: Chrome repeat run is beginning with JS instead of Document
Only thing that comes to mind is an instrumentation oddity with Chrome.

I rely on Chrome's dev tools for SSL traffic and Chrome has an interesting behavior where it requests the base page before it creates the renderer for the page but the timing data is tied to the renderer so anything that happens before the renderer starts up may not be visible. There are a bunch of things in place to minimize the impact but every now and then you see strange things like that.

For IE and Firefox I can get the SSL measurements directly from the networking stack so the measurements tend to be more complete.
Visit this user's website Find all posts by this user
Quote this message in a reply
04-29-2014, 04:30 AM
Post: #3
RE: Chrome repeat run is beginning with JS instead of Document
Code:
Leverage browser caching of static assets: 76/100

FAILED - (No max-age or expires) - https://sproutsocial.com/signup/start/premium_v3
FAILED - (No max-age or expires) - https://munchkin.marketo.net/munchkin.js
WARNING - (1.0 hours) - https://tracker.marinsm.com/tracker/async/c0otnfhoc0.js
WARNING - (12.0 hours) - https://stats.g.doubleclick.net/dc.js
Find all posts by this user
Quote this message in a reply
04-29-2014, 05:00 AM
Post: #4
RE: Chrome repeat run is beginning with JS instead of Document
@Anton - the problem is that the base HTML page isn't showing up in the waterfall even though it has a max-age of 0. That and the missing SSL negotiation point to the requests being made but not logged. Unfortunately getting SSL data out of Chrome is a lot more difficult than the other browsers.
Visit this user's website Find all posts by this user
Quote this message in a reply
04-29-2014, 06:26 AM
Post: #5
RE: Chrome repeat run is beginning with JS instead of Document
(04-29-2014 05:00 AM)pmeenan Wrote:  @Anton - the problem is that the base HTML page isn't showing up in the waterfall even though it has a max-age of 0. That and the missing SSL negotiation point to the requests being made but not logged. Unfortunately getting SSL data out of Chrome is a lot more difficult than the other browsers.
Right but, he is talking about second run. First run is fine. The only things the second run should be picking up is things that weren't cached the first time. Am I wrong about that?
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)