Current time: 12-17-2017, 04:41 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
2.14 upgrade/sqlite assistance
05-17-2014, 07:40 AM
Post: #1
2.14 upgrade/sqlite assistance
I wonder if someone has run into this issue:

2.12 install - Test History worked perfectly (all other functions work)
2.14 update - Test History php list is empty (all other functions work)

2.14 Files were downloaded from the 2.14 doc link - not git. Overlayed the existing www install. Updated "settings" and restarted. Only the 1 function fails.

I ended up debugging the "testlog.php" -> getLabel (common_lib.inc) function which makes a SQLite3 call. This is dying as I don't have a ./dat/labels.db.

sqlite> .databases
seq name file
--- --------------- ----------------------------------------------------------
0 main
1 temp


1) What creates the "sqlite3" database elements? Did I miss something in the install/upgrade?
2) In reviewing the downloaded 2.14.zip file (download via the documentation link) I do not see the "viewsqlite.php", yet in git I see it is packaged in the 2.14 release (in documentation and via git clone). Is that intentional?

Any ideas on how to get the sqlite db and Test History functionality back on track?

Thanks in advance
Find all posts by this user
Quote this message in a reply
05-23-2014, 12:37 AM
Post: #2
RE: 2.14 upgrade/sqlite assistance
The sqlite call shouldn't die because it's supposed to be checking for the existence before even making the call. I think there was a problem with runtest.php not recording the owner information correctly that I fixed a little while back that is probably the reason for the missing history: https://github.com/WPO-Foundation/webpag...9313669157

If you take that one-liner hopefully that's all that is needed.
Visit this user's website Find all posts by this user
Quote this message in a reply
06-10-2014, 01:59 AM (This post was last modified: 06-10-2014 02:07 AM by miquelangeld.)
Post: #3
RE: 2.14 upgrade/sqlite assistance
Hi Patrick, I have exactly the same issue, I updated to 2.14 version but I don't overwrite the old installation I created a new ine and then copied the settings and the results folder. But in history the new tests are not listed noor the old.

I checked the line that you mentioned and seems to be ok.

thanks in advance.

(05-23-2014 12:37 AM)pmeenan Wrote:  The sqlite call shouldn't die because it's supposed to be checking for the existence before even making the call. I think there was a problem with runtest.php not recording the owner information correctly that I fixed a little while back that is probably the reason for the missing history: https://github.com/WPO-Foundation/webpag...9313669157

If you take that one-liner hopefully that's all that is needed.
Find all posts by this user
Quote this message in a reply
06-19-2014, 12:34 AM
Post: #4
RE: 2.14 upgrade/sqlite assistance
Thanks, finally it's working.

(06-10-2014 01:59 AM)miquelangeld Wrote:  Hi Patrick, I have exactly the same issue, I updated to 2.14 version but I don't overwrite the old installation I created a new ine and then copied the settings and the results folder. But in history the new tests are not listed noor the old.

I checked the line that you mentioned and seems to be ok.

thanks in advance.

(05-23-2014 12:37 AM)pmeenan Wrote:  The sqlite call shouldn't die because it's supposed to be checking for the existence before even making the call. I think there was a problem with runtest.php not recording the owner information correctly that I fixed a little while back that is probably the reason for the missing history: https://github.com/WPO-Foundation/webpag...9313669157

If you take that one-liner hopefully that's all that is needed.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)