Current time: 11-26-2020, 11:03 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
TTFB (12 secs +)
07-25-2014, 01:21 AM
Post: #1
TTFB (12 secs +)
Hi there - hoping for a bit of assistance with narrowing down the cause of a slow page-load.

I'm experiencing very high TTFB: http://www.webpagetest.org/result/140724...3d6aa26da/

I've setup a static html page which loads quickly and was hoping someone could help identify whether the slow loading is server-based or something else.

Many thanks in advance.
Find all posts by this user
Quote this message in a reply
07-25-2014, 06:01 AM
Post: #2
RE: TTFB (12 secs +)
I noticed that you have Apache. You have something in the backend that is taking a long time to load. Usually a DB call, or 3rd party plugin.

Could you add the following PHP command in your "static" html: <?php flush(); ?> after the <title>Legalease Law Journals | Commercial Litigation | Employment | Family | Personal Injury | Property | Procurement &amp; Outsourcing | Trusts and Estates Law &amp; Tax</title>

I'm pretty sure it's either the theme, or the CMS you are using.
Find all posts by this user
Quote this message in a reply
07-26-2014, 06:07 AM
Post: #3
RE: TTFB (12 secs +)
The initial response from your server is really slow, are you using shared hosting or something similar?

Even if you fix I'm guessing you're going to have a slow rendering page due to the number of CSS files etc.

Andy

Using WebPageTest - http://usingwpt.com/
Visit this user's website Find all posts by this user
Quote this message in a reply
07-29-2014, 07:18 PM
Post: #4
RE: TTFB (12 secs +)
(07-26-2014 06:07 AM)andydavies Wrote:  The initial response from your server is really slow, are you using shared hosting or something similar?

Even if you fix I'm guessing you're going to have a slow rendering page due to the number of CSS files etc.

Thanks both - and apologies for the delay in response - bit of a running theme here!

I've tried php flush and no real impact. I'm pretty sure it's something to do with the server setup (shared and out of my hands) so really just looking to rule out any settings or frontend based issues that I could potentially resolve.
Find all posts by this user
Quote this message in a reply
07-30-2014, 05:48 AM
Post: #5
RE: TTFB (12 secs +)
Here is a trick. Create a blank HTML file, upload it and run a WPT. If you have the same TTFB time, it's your shared hosting, if not, we can trouble shoot from there.

You might not have flushing enabled. http://stackoverflow.com/questions/47065...ot-working
Find all posts by this user
Quote this message in a reply
08-01-2014, 02:01 AM
Post: #6
RE: TTFB (12 secs +)
Thanks Marc - significantly lower TTFB on that static one: http://www.webpagetest.org/result/140731...b62450fa1/

Appreciate your assistance.


(07-30-2014 05:48 AM)mrPerezMarc Wrote:  Here is a trick. Create a blank HTML file, upload it and run a WPT. If you have the same TTFB time, it's your shared hosting, if not, we can trouble shoot from there.

You might not have flushing enabled. http://stackoverflow.com/questions/47065...ot-working
Find all posts by this user
Quote this message in a reply
08-01-2014, 07:33 AM
Post: #7
RE: TTFB (12 secs +)
Tada Smile I ran a test, and your site is responding better. Let me know if you need anything else.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)