Current time: 12-14-2017, 12:40 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
(Error: 2147483647) for FF tests
11-17-2014, 02:57 PM (This post was last modified: 11-17-2014 02:59 PM by deivanaixyz.)
Post: #1
(Error: 2147483647) for FF tests
FF tests show 'Untrusted connection' message and fail without loading the page for https URLs
It always ends up with this (Error: 2147483647).
However the same URL works fine on IE8 and IE10
Find all posts by this user
Quote this message in a reply
11-18-2014, 06:14 AM
Post: #2
RE: (Error: 2147483647) for FF tests
For all sites? Public or Private instance? Could be differences in the root certificate lists or other browser-specific policies.
Visit this user's website Find all posts by this user
Quote this message in a reply
11-18-2014, 07:13 PM
Post: #3
RE: (Error: 2147483647) for FF tests
Private instance. How can I fix this. Where should I include the keys?
Find all posts by this user
Quote this message in a reply
11-22-2014, 02:20 AM
Post: #4
RE: (Error: 2147483647) for FF tests
The best way to fix it is to figure out what in your network path is intercepting your traffic and bypass it. If you are being directed to a staging server then it should have the production keys.

If you need to install a new trust anchor on the machine you will need to do it on the test agent. Most browsers will use the OS cert store. If Firefox doesn't then you'll need to update the Firefox profile template in agent/templates/firefox to have the key.

You can also run tests with the "Ignore Certificate Errors" setting checked but that's not a good long-term strategy.
Visit this user's website Find all posts by this user
Quote this message in a reply
11-25-2014, 04:21 PM
Post: #5
RE: (Error: 2147483647) for FF tests
How do I update the keys in agent/templates/firefox?

I tried adding the following lines to pref.js
user_pref("network.automatic-ntlm-auth.trusted-uris", "xxx_uri,goto");
user_pref("network.negotiate-auth.delegation-uris", "xxx_uri,goto");
user_pref("network.negotiate-auth.trusted-uris", "xxx_uri,goto");

But still I get 'Untrusted connection' messages
Find all posts by this user
Quote this message in a reply
11-26-2014, 12:29 AM
Post: #6
RE: (Error: 2147483647) for FF tests
Firefox does not allow you to disable certificate checks through preferences. WebPagetest does it by hooking the internal cert verification API calls inside of Firefox.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)