Current time: 11-12-2019, 06:23 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CSS hosted on CDN doesn't load on test but OK in real life
02-18-2015, 03:25 AM
Post: #1
CSS hosted on CDN doesn't load on test but OK in real life
I've got a site I'm looking after the hosting for - http://www.ski-insurance.com.au - and we've moved the assets (css etc) to a CDN. Since doing so, if I do a webpagetest on it (e.g. http://www.webpagetest.org/result/150217_81_WN7/ ), it doesn't load the CSS and the assets in it.

Looking at the site in real life works fine though, as does testing it through numerous browsers on browserstack.com, so it seems to be a problem with the webpagetest.org stuff?

Any ideas?
Find all posts by this user
Quote this message in a reply
02-18-2015, 06:49 AM
Post: #2
RE: CSS hosted on CDN doesn't load on test but OK in real life
Try enabling "preserve user agent string" in the advanced settings. It's possible that your CDN is blocking the traffic with the PTST UA string (would be really bizarre but possible).
Visit this user's website Find all posts by this user
Quote this message in a reply
02-18-2015, 05:11 PM
Post: #3
RE: CSS hosted on CDN doesn't load on test but OK in real life
Thanks, tried that to no avail.

It's not actually a CDN, it's just an nginx cluster I've setup on AWS that acts as a reverse proxy to take some bandwidth load off the main environment, so I control it all!

Very weird that it only doesn't work in WPT but everything else seems fine!
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)