Current time: 10-14-2019, 08:21 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
wptdriver prevents caching
05-12-2015, 07:03 PM
Post: #1
wptdriver prevents caching
Hi.

I noticed that on my private instance testing machines static assets with properly set expiration headers are not cached by Internet Explorer. What is interesting this happens only when tested with webpagetest. When checked manually with fiddler, the browser caches everything properly.

What is possible reason for that? "Check for newer versions of stored pages" is set to "automatically" - default setting. I have no idea what else can interfere with caching. The only correlation I noticed is that caching problem applies to IE11. On machines running IE9 I cannot notice anything like that.

Artur Sudnik
Find all posts by this user
Quote this message in a reply
05-26-2015, 01:28 AM
Post: #2
RE: wptdriver prevents caching
Here is an example of such behaviour: http://www.webpagetest.org/result/150525...d44e9ad88/

For example http://cdn.webpagetest.org/pagestyle.css?v=68 is cached by IE11 when loaded while opening tested page manually.

Artur Sudnik
Find all posts by this user
Quote this message in a reply
06-10-2015, 11:33 PM (This post was last modified: 06-11-2015 12:02 AM by ash.)
Post: #3
RE: wptdriver prevents caching
Does anyone have similar issue?

Another more clear example: http://www.webpagetest.org/result/150610...611b13c06/

why caching headers are ignored when tested by webpagetest and IE11?

Firefox behaves correctly while driven by wptdriver: http://www.webpagetest.org/result/150610...30af59118/

Artur Sudnik
Find all posts by this user
Quote this message in a reply
06-11-2015, 12:06 AM
Post: #4
RE: wptdriver prevents caching
That's really bizarre and it doesn't look to be universal, just specific locations: http://www.webpagetest.org/result/150610...9a90491a0/

I wonder if it is OS-specific or if something else strange is going on. What OS are you running IE 11 on?
Visit this user's website Find all posts by this user
Quote this message in a reply
06-11-2015, 12:07 AM (This post was last modified: 06-11-2015 12:44 AM by ash.)
Post: #5
RE: wptdriver prevents caching
Yes, I have similar impression but I have too few variations of agents versions on my private WPT instance to be sure what is going on.

Resetting IE settings to defaults does not help. Some time ago removing whole windows user profile helped but not in case of IE11 now.

Sorry - forget to write that i run IE 11 on Windows 7

I raised an issue on github: https://github.com/WPO-Foundation/webpag...issues/448

Artur Sudnik
Find all posts by this user
Quote this message in a reply
07-03-2015, 06:34 PM
Post: #6
RE: wptdriver prevents caching
I still try to investigate deeper this issue and have just figured out that when I open pages manually with IE 11 and while dev. tools panel is active, some assets are not fetched from cache but from the server. I verified it with fiddler to be sure.

"Always refresh from server" option is not active for sure.

Maybe there is something around it that causes this behavior when testing with wptdriver?

Artur Sudnik
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)