Current time: 12-17-2017, 04:17 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
403 When using Bulktest
05-16-2015, 12:45 AM
Post: #1
403 When using Bulktest
Hi,

Im getting 403's when testing via the php bulktest api, the same sites work ok via the gui.

API: http://52.11.187.148/result/150515_AX_7/

GUI: http://52.11.187.148/result/150515_WV_6/

The only things I have changed are urls.txt and added my API key to settings.inc I've also set the server to be 127.0.0.1 as I am running this on the web server.

I can wget this site from the server cli with no problems, any suggestions would be greatly appreciated!

Cheers

Sam
Find all posts by this user
Quote this message in a reply
05-18-2015, 10:34 PM
Post: #2
RE: 403 When using Bulktest
I've tested this from my local PC via the php api with the same results, here are the request headers for both results:

Working via GUI: http://52.11.187.148/result/150515_WV_6/1/details/

- Request 1: http://www.chroniclelive.co.uk/
URL: http://www.chroniclelive.co.uk/
Host: http://www.chroniclelive.co.uk
IP: 190.98.130.170
Error/Status Code: 200
Client Port: 49216
Request Start: 0.355 s
Initial Connection: 34 ms
Time to First Byte: 265 ms
Content Download: 277 ms
Bytes In (downloaded): 38.9 KB
Bytes Out (uploaded): 0.4 KB
Request Headers:

GET / HTTP/1.1
Host: http://www.chroniclelive.co.uk
Connection: keep-alive
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.90 Safari/537.36 PTST/210
Accept-Encoding: gzip, deflate, sdch
Accept-Language: en-US,en;q=0.8
Response Headers:

HTTP/1.1 200 OK
Access-Control-Allow-Origin: *
Content-Encoding: gzip
Content-Type: text/html;charset=UTF-8
Server: nginx
X-Cache-Hits: 2
X-Cacheable: YES
X-ProcessESI: yes
X-RemovedCookies: YES
X-Served-By: reg-cache1a.tm-aws.com
X-Varnish: 874910373 874904503
Content-Length: 39427
Cache-Control: max-age=4
Date: Fri, 15 May 2015 12:22:06 GMT
Connection: keep-alive
Set-Cookie: stop_mobi=true; path=/
Vary: Accept-Encoding,User-Agent

============================================================================

Failing via API: http://52.11.187.148/result/150518_0Z_8/5/details/

- Request 1: http://www.chroniclelive.co.uk/
URL: http://www.chroniclelive.co.uk/
Host: http://www.chroniclelive.co.uk
IP: 72.66.115.11
Error/Status Code: 403
Client Port: 49909
Request Start: 0.069 s
Initial Connection: 37 ms
Time to First Byte: 40 ms
Bytes In (downloaded): 0.4 KB
Bytes Out (uploaded): 0.4 KB
Request Headers:

GET / HTTP/1.1
Host: http://www.chroniclelive.co.uk
X-Jpeg-Mode: 2
Connection: keep-alive
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.90 Safari/537.36
Accept-Encoding: gzip, deflate, sdch
Accept-Language: en-US,en;q=0.8
Response Headers:

HTTP/1.1 403 Forbidden
Server: nginx/1.4.6 (Ubuntu)
Date: Mon, 18 May 2015 12:11:57 GMT
Content-Type: text/html
Transfer-Encoding: chunked
Connection: keep-alive
Content-Encoding: gzip
Find all posts by this user
Quote this message in a reply
05-21-2015, 12:13 AM
Post: #3
RE: 403 When using Bulktest
there was a script parameter set in submit.php which was causing this, part of the example data i guess
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)