Current time: 12-08-2019, 12:34 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Solved] Something going haywire help please
08-27-2015, 05:58 PM (This post was last modified: 08-30-2015 12:40 AM by viv2xlr8.)
Post: #1
[Solved] Something going haywire help please
[Solved Edit:
I changed hosting and problems disappeared. Now back to further speed optimizations.

I read on WPT forums that it is either the DOM or Server Configuration when there are severe issues. In this case it was the server configuration. Support at the former host was lacking so the move was imperative.] End Edit.

Two weeks ago I was working to optimize for the first time and had this heavy Wordpress homepage finally coming down to a 4-1/2 second load.

I am now so slow I am off other tool's charts but WPT still finishes. It's bad.

After that first effort I needed to stop and do other things. Meanwhile something has changed. Don't know what.

The only thing that I can think of is maybe a plugin update got done but I can't isolate it if that is the cause.

I made the keep-alive adjustment and it helped but not enough. I will work on cache next but right now the way this is I won't have to worry about return visitors.

I need pro input because the chart does not even look right (to me).

http://www.webpagetest.org/result/150827_ZA_9GZ/

This is a traceroute test if it helps:
http://www.webpagetest.org/result/150827_DZ_9VA/

Here is my htacess if it helps:
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

# Keep-Alive Connections
<ifModule mod_headers.c>
Header set Connection keep-alive
</ifModule>

# END Keep-Alive

# 301 Redirect www to non-www
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{HTTP_HOST} ^www\.(.*) [NC]
RewriteRule ^(.*)$ http://%1/$1/ [R=301,NC,L]
</IfModule>

# END 301 Redirect www to non-www

<IfModule mod_deflate.c>
# Insert filters
AddOutputFilterByType DEFLATE text/plain
AddOutputFilterByType DEFLATE text/html
AddOutputFilterByType DEFLATE text/xml
AddOutputFilterByType DEFLATE text/css
AddOutputFilterByType DEFLATE application/xml
AddOutputFilterByType DEFLATE application/xhtml+xml
AddOutputFilterByType DEFLATE application/rss+xml
AddOutputFilterByType DEFLATE application/javascript
AddOutputFilterByType DEFLATE application/x-javascript
AddOutputFilterByType DEFLATE application/x-httpd-php
AddOutputFilterByType DEFLATE application/x-httpd-fastphp
AddOutputFilterByType DEFLATE image/svg+xml

# Drop problematic browsers
BrowserMatch ^Mozilla/4 gzip-only-text/html
BrowserMatch ^Mozilla/4\.0[678] no-gzip
BrowserMatch \bMSI[E] !no-gzip !gzip-only-text/html

# Make sure proxies dont deliver the wrong content
Header append Vary User-Agent env=!dont-vary
</IfModule>
<IfModule mod_rewrite.c>

Deny from env=BlockCountry
</IfModule>



<IfModule mod_rewrite.c>
SetEnvIf GEOIP_COUNTRY_CODE DZ BlockCountry

(...lots and lots more country codes...)

Deny from env=BlockCountry
</IfModule>
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)