Current time: 10-16-2019, 09:39 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Slight problem with WebPageTest jpeg image reporting
09-05-2015, 12:39 AM
Post: #1
Slight problem with WebPageTest jpeg image reporting
I've been noticing this recently. Thought it was just people using some tool to generated or compress jpeg images that was somehow generating broken jpegs.

After looking deeply at two people's sites today, it appears WebPageTest is having problems with correctly processing jpeg files.

http://www.webpagetest.org/result/150904.../2/details is an example.

Notice "Compress Images" shows N/A + clicking on this really does say N/A for both compression + progressive for all jpeg images.

This appears incorrect, as there are many jpeg images on this person's site + looking at them with ImageMagick - identify -verbose - seems to indicate image structure is correct.

Unsure if this is the correct place to report this.

If not, let me know the correct place.

Thanks.

Like help speeding up your site? Skype me @ ID davidfavor for a quote. Be sure to include your site name in your Skype Add Contact request.
Find all posts by this user
Quote this message in a reply
09-09-2015, 11:01 PM
Post: #2
RE: Slight problem with WebPageTest jpeg image reporting
It's an issue with Chrome HTTPS content. The WebPageTest agents don't have access to the body of HTTPS requests in Chrome (yet) so the JPEG decode and text compression tests can't be run (hence the N/A).

The github issue tracker is the best place to report and track issues. There's an existing one for not having access to bodies for HTTPS requests on Chrome: https://github.com/WPO-Foundation/webpag...issues/272
Visit this user's website Find all posts by this user
Quote this message in a reply
09-10-2015, 02:35 AM
Post: #3
RE: Slight problem with WebPageTest jpeg image reporting
Ah... Got it.

Thanks!

Like help speeding up your site? Skype me @ ID davidfavor for a quote. Be sure to include your site name in your Skype Add Contact request.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)