Current time: 09-22-2019, 08:41 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Bytes in columns are always 0kb
09-10-2015, 12:24 AM
Post: #1
Bytes in columns are always 0kb
Hi,

in our private instance, all our test pages with desktop Chrome have always 0kb in the both Byte in columns. In desktop Firefox it is fine as well as in a mobile Chrome. The results byte in json files don't have records for the Chrome location for some reason. All other columns have records.

It looks like a missconfiguration, but have no idea what could be the reason. Could you give me a hint?

Kind regards
Find all posts by this user
Quote this message in a reply
09-10-2015, 11:05 PM
Post: #2
RE: Bytes in columns are always 0kb
Hi,

I've just been trying to figure out the same problem, after coming back to a windows agent after my linux/nodejs chrome agent didn't work out too well.

Yup, same here, bytes in zero in Document Complete and Fully loaded.

Also URL's in waterfall are showing up strangely, i.e. http://www.mysite.comhttp://www.mysite.com/

Any ideas anyone?

-John.
Find all posts by this user
Quote this message in a reply
09-14-2015, 08:01 AM
Post: #3
RE: Bytes in columns are always 0kb
Hi,

I've done a little bit of investigation work around the zero bytes problem on my side. We have to use a CNTLM proxy infront of our main authenticating proxy. I setup a non-proxied virtual environment and everything (as expected) worked correctly, URL's and Bytes-In were correct.

I then added in an NTLM proxy, and a cntlm proxy in front, and gave chrome the --proxy-pac-url directive - and Hay Presto! it gave a 0 Bytes In result, and messed up URL's as in my above post.

Stydentsa - Do you have a proxy being used in your setup?

This week I'm going to look into setting up a transparent proxy instead of the cntlm one, and see if that will allow the correct url's and results.

-John.
Find all posts by this user
Quote this message in a reply
09-14-2015, 06:28 PM
Post: #4
RE: Bytes in columns are always 0kb
Hi John,

great work! Yes we have a proxy behind. I'll play around and let you know for the result.

Best regards
Find all posts by this user
Quote this message in a reply
09-22-2015, 12:19 AM
Post: #5
RE: Bytes in columns are always 0kb
Quick update

As soon as I'd typed the last reply I slapped myself around the head, because although transparent proxying is easy on Linux, on Windows - not too easy - at least without routing all traffic from the windows machine through a linux box etc.

I have however found one piece of software that allows the transparent redirection of outgoing connections on a Windows machine to another host/port. The software is called MultiPortForwarder, and can be found here http://www.verigio.com/products/multi-po...fault.aspx

I've tested it in my virtualised environment and it worked fine, now i'm setting it up to run against our main ntlm proxy. I'm redirecting all 80 and 443 traffic to a linux box running Squid in transparent mode, which in turn uses our main proxy and provides it with the NTLM credentials needed.

Hope this helps others in a similar situation.

-John.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)