Current time: 04-11-2020, 06:15 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
What's slowing down my site? High TTFB or something else?
02-02-2016, 09:16 AM
Post: #3
RE: What's slowing down my site? High TTFB or something else?
hi kuurt,
1. The TTFB is not always so high. I made some tests the last days for your page. The TTFB varies between 0.3sec and more than 3sec. I think this a sign that the problem come from your Hoster. If they have many sites on the server and there is much traffic all slows down. The TTFB for your page goes up.
(You linked an article from cludflare. I think if you see that the complete pageload goes up and down with an longer TTFB this is a real problem. The user has to wait to see your page!)
Here you find a thread about this problem:
http://www.webpagetest.org/forums/showth...hp?tid=906

1 b) And I tested today: http://www.webpagetest.org/result/160201_D7_17ZS/
There you had a TTFB with an A-Grade, but the styles.php loading very long after that.
I dont know why, perhaps the server don't work constantly fast enough??
(The styles.php is a small file with some of your css - dont know if it is effective to load it this way - or if it slows down the loading process?)
Perhaps you make a test and place a link to your result here without your rocket-plugin to see whats changing.

2. About optimizing your images. If you look in your test here on webpagetest. Under the 'Waterfall-View' you find a link 'View all images'.
You can see results for your optimized images.
Following the link for your home.jpg you get the optimized images
http://www.webpagetest.org/jpeginfo/jpeg...gHome1.jpg

So the plugin you use dont get the best possible results.

Your header grafic is an png-file.
For optimise png you have a free online-tool.
http://www.tinypng.com
A test I made with your header reduces the size from 183kB to 44kb (-76%)
(it would be more small as jpg-file but its a question of quality )

5. Font-Loading: Your page-text renders in 'Arial'.
But the google fonts 'Droid Sans' and 'pt sans' are loaded.
One of this fonts only used for the navigation.
If you dont need the special google fonts perhaps you can deactivate these in your wordpress-template?
(On the other side you see in the waterfall that the page shows up before the fonts are loaded. First the page shows up with an other font and after later loading the webfont it renders the page with the webfont)

I am from Germany - sorry for my not so fine english. Here I had same problems with my hoster and changing to a better hoster was the solution and in my case with lower cost.

greetings kay
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
RE: What's slowing down my site? High TTFB or something else? - kayferdinand - 02-02-2016 09:16 AM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)