Current time: 12-12-2019, 07:01 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Gap in TLS connection/handshake
03-12-2016, 05:26 AM
Post: #1
Gap in TLS connection/handshake
Hi Patrick,

What a great site and healthy forum! I've been following for a long time, but am only now making my first post.

I always am seeing gaps in my initial file request. For example:
http://www.webpagetest.org/result/160311...1/details/
http://www.webpagetest.org/result/160311_02_14W8/

Could you provide any details as to what's happening? We're using http2 with OCSP stapling, but still getting long TLS connections/handshakes.

I have also read in other user posts, you mention to look in firefox for more details about the gaps/SSL. I can't seem to find where these details are in FF. Is this in the Firefox developer edition? Is it the standard Network view (because here, I see the same level of detail as what's on WPT)?

Any other recommendations you can make on quick glance, including SSL?

I appreciate the assistance!
Find all posts by this user
Quote this message in a reply
03-16-2016, 01:17 AM
Post: #2
RE: Gap in TLS connection/handshake
Your best bet is to enable tcpdump (advanced settings) and netlog (chrome tab) which will give you details about the internals and what is going on. If the time really comes between DNS and the socket connect I'm afraid it is something in Chrome and out of your control (that is long before it even knows there is a certificate to check).

Do you see it consistently? I tried re-running the test a couple of times and didn't see it happen.
Visit this user's website Find all posts by this user
Quote this message in a reply
03-16-2016, 01:23 AM
Post: #3
RE: Gap in TLS connection/handshake
As far as recommendations, it's hard to argue about a site that gets most of the main content up in 1.1s: http://www.webpagetest.org/video/compare...end=visual

My only recommendations after a quick look:
- Get rid of the "Norton Secured" seal. It's a complete sham and there's no reason to run the code
- The "contact golfscape" zopim code is what pushes the visual complete out to 4+ seconds. It would be worthwhile to see if you can get it to load sooner
- Are you actually leveraging rocket loader for the performance? If not you might do better by removing it and manually tuning
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)